aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Stenger <christian.stenger@qt.io>2021-01-29 09:05:16 +0100
committerChristian Stenger <christian.stenger@qt.io>2021-02-05 14:09:12 +0000
commitced96a480d51fd6eb6e30d0141cb427f00ef234e (patch)
tree45d200ae8f007064854d2a0555c676d8ebc97d8f /CMakeLists.txt
parent765f518de35ae5d546a8fd9d9e36b7f3ad4ca103 (diff)
CMake: merge binary directories of sub projects
...into top level. Exceptions are applied explicitly. Change-Id: I59c54967dffc0bef2e8cc05c73763fcf18c12517 Reviewed-by: Eike Ziller <eike.ziller@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b23103fdff..d6efaa8cdd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,6 +27,9 @@ add_feature_info("Build tests" ${WITH_TESTS} "")
option(WITH_DEBUG_CMAKE "Enabled CMake project debugging functionality (e.g. source file disk checking)" OFF)
option(BUILD_WITH_PCH "Build with precompiled headers" ON)
+# merge binary directories of sub projects into top level
+set(QTC_MERGE_BINARY_DIR ON)
+
set(CMAKE_INCLUDE_CURRENT_DIR ON)
# Set up Qt stuff: