aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCristian Adam <cristian.adam@qt.io>2020-02-05 19:38:18 +0100
committerAlessandro Portale <alessandro.portale@qt.io>2020-02-06 18:03:33 +0000
commit8d767a3a2139b710f97e3b14553aa98fdae1362f (patch)
treed00d83ca8fe20e4f0fc65bfb9c001f7003471060 /CMakeLists.txt
parentdecb6866b91cb0023ed71f7a5186520a8ce20d03 (diff)
CMake Deployment: Remove Dependencies component
- Install will also copy the dependencies. - Made the dependencies search recursive, not just two steps - Moved install code to a script, not having to escape quotes and dollars Change-Id: I6c5fb19e4094e9dcd4b339d5b90be6e7c5055223 Reviewed-by: Alessandro Portale <alessandro.portale@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 44a5ad6a7e..c4077ac3e9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -138,6 +138,11 @@ endif()
add_subdirectory(doc)
+# CMake will include in a cmake_install.cmake at the end the subdirectories
+# At this point all the previous install scripts have been included
+# Deployment is being done in cmake/CMakeLists.txt
+add_subdirectory(cmake)
+
feature_summary(INCLUDE_QUIET_PACKAGES WHAT
PACKAGES_FOUND PACKAGES_NOT_FOUND
ENABLED_FEATURES DISABLED_FEATURES