aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-05-29 16:29:43 +0200
committerTobias Hunger <tobias.hunger@qt.io>2019-06-05 13:00:22 +0000
commit1ce6c4abc37af3ab08cd3a5794ff1f3aece9a9c4 (patch)
treecc2cb944da82e21cace9c42566a6242409036acd /src/CMakeLists.txt
parentce59cf6a50d01f77854c4202ce89a9157e1ea80d (diff)
CMake: Do not include libraries in "all" target
This makes sure creator will not build libraries that are not needed by the plugins that are enabled. Change-Id: Ia568d56be24d47d895d70cc78f6601dd611f1aaa Reviewed-by: Cristian Adam <cristian.adam@qt.io> Reviewed-by: Alessandro Portale <alessandro.portale@qt.io>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index b59ba91aec..cf807a680e 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -126,7 +126,8 @@ function(add_qtc_library name)
set(library_type OBJECT)
endif()
- add_library(${name} ${library_type} ${_arg_SOURCES})
+ # Do not just build libraries...
+ add_library(${name} ${library_type} EXCLUDE_FROM_ALL ${_arg_SOURCES})
if (${name} MATCHES "^[^0-9]+")
string(TOUPPER "${name}_LIBRARY" EXPORT_SYMBOL)