aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/designer/CMakeLists.txt
diff options
context:
space:
mode:
authorCristian Adam <cristian.adam@gmail.com>2019-05-12 22:20:56 +0200
committerCristian Adam <cristian.adam@gmail.com>2019-05-17 13:33:28 +0000
commitd855b84c5df923394ace3bb91dab379f7e0daa34 (patch)
treee184ccdf5724151465a1653f9fc308af43293de8 /src/plugins/designer/CMakeLists.txt
parentf872a95fddd2690bb6953a17e48935c1b12d83d9 (diff)
Qt Creator CMake port
Based on Tobias Hunger's work from a few months ago. The CMake configuration needs libclang and Qt paths specified as CMAKE_PREFIX_PATH. Auto tests are run with "ctest". At the moment the pass rate is 87%. Change-Id: Iba98e39bf22077d52706dce6c85986be67a6eab0 Reviewed-by: Alessandro Portale <alessandro.portale@qt.io> Reviewed-by: Tobias Hunger <tobias.hunger@qt.io> Reviewed-by: Eike Ziller <eike.ziller@qt.io>
Diffstat (limited to 'src/plugins/designer/CMakeLists.txt')
-rw-r--r--src/plugins/designer/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/src/plugins/designer/CMakeLists.txt b/src/plugins/designer/CMakeLists.txt
new file mode 100644
index 0000000000..52f7b53e18
--- /dev/null
+++ b/src/plugins/designer/CMakeLists.txt
@@ -0,0 +1,41 @@
+# Qt5::DesignerComponents doesn't have a target, so we need to define our own:-/
+find_package(DesignerComponents)
+
+if (WITH_TESTS)
+ set(TST_COMPONENT CppEditor)
+endif()
+
+add_qtc_plugin(Designer
+ CONDITION TARGET Qt5::DesignerComponents AND TARGET Qt5::Designer
+ DEPENDS designerintegrationv2
+ Qt5::Designer Qt5::PrintSupport Qt5::DesignerComponents
+ DEFINES CPP_ENABLED
+ PLUGIN_DEPENDS Core CppTools ProjectExplorer QtSupport ResourceEditor TextEditor ${TST_COMPONENT}
+ SOURCES
+ codemodelhelpers.cpp codemodelhelpers.h
+ cpp/formclasswizard.cpp cpp/formclasswizard.h
+ cpp/formclasswizarddialog.cpp cpp/formclasswizarddialog.h
+ cpp/formclasswizardpage.cpp cpp/formclasswizardpage.h cpp/formclasswizardpage.ui
+ cpp/formclasswizardparameters.cpp cpp/formclasswizardparameters.h
+ designer_export.h
+ designerconstants.h
+ designercontext.cpp designercontext.h
+ editordata.h
+ editorwidget.cpp editorwidget.h
+ formeditorfactory.cpp formeditorfactory.h
+ formeditorplugin.cpp formeditorplugin.h
+ formeditorstack.cpp formeditorstack.h
+ formeditorw.cpp formeditorw.h
+ formtemplatewizardpage.cpp formtemplatewizardpage.h
+ formwindoweditor.cpp formwindoweditor.h
+ formwindowfile.cpp formwindowfile.h
+ qtcreatorintegration.cpp qtcreatorintegration.h
+ qtdesignerformclasscodegenerator.cpp qtdesignerformclasscodegenerator.h
+ resourcehandler.cpp resourcehandler.h
+ settingsmanager.cpp settingsmanager.h
+ settingspage.cpp settingspage.h
+)
+
+if (WITH_TESTS)
+ target_sources(Designer PRIVATE gotoslot_test.cpp)
+endif()