aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/fakevim/CMakeLists.txt
diff options
context:
space:
mode:
authorCristian Adam <cristian.adam@gmail.com>2019-05-12 22:20:56 +0200
committerCristian Adam <cristian.adam@gmail.com>2019-05-17 13:33:28 +0000
commitd855b84c5df923394ace3bb91dab379f7e0daa34 (patch)
treee184ccdf5724151465a1653f9fc308af43293de8 /src/plugins/fakevim/CMakeLists.txt
parentf872a95fddd2690bb6953a17e48935c1b12d83d9 (diff)
Qt Creator CMake port
Based on Tobias Hunger's work from a few months ago. The CMake configuration needs libclang and Qt paths specified as CMAKE_PREFIX_PATH. Auto tests are run with "ctest". At the moment the pass rate is 87%. Change-Id: Iba98e39bf22077d52706dce6c85986be67a6eab0 Reviewed-by: Alessandro Portale <alessandro.portale@qt.io> Reviewed-by: Tobias Hunger <tobias.hunger@qt.io> Reviewed-by: Eike Ziller <eike.ziller@qt.io>
Diffstat (limited to 'src/plugins/fakevim/CMakeLists.txt')
-rw-r--r--src/plugins/fakevim/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/plugins/fakevim/CMakeLists.txt b/src/plugins/fakevim/CMakeLists.txt
new file mode 100644
index 0000000000..3363c12c75
--- /dev/null
+++ b/src/plugins/fakevim/CMakeLists.txt
@@ -0,0 +1,18 @@
+if (WITH_TESTS)
+ set(TST_COMPONENT CppEditor CppTools)
+endif()
+
+add_qtc_plugin(FakeVim
+ PLUGIN_DEPENDS Core TextEditor ${TST_COMPONENT}
+ SOURCES ${TEST_SOURCES}
+ fakevim.qrc
+ fakevimactions.cpp fakevimactions.h
+ fakevimhandler.cpp fakevimhandler.h
+ fakevimoptions.ui
+ fakevimplugin.cpp fakevimplugin.h
+ fakevimtr.h
+)
+
+if (WITH_TESTS)
+ target_sources(FakeVim PRIVATE fakevim_test.cpp)
+endif()