aboutsummaryrefslogtreecommitdiffstats
path: root/share/qtcreator/templates/wizards/projects/qtwidgetsapplication/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'share/qtcreator/templates/wizards/projects/qtwidgetsapplication/meson.build')
-rw-r--r--share/qtcreator/templates/wizards/projects/qtwidgetsapplication/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/share/qtcreator/templates/wizards/projects/qtwidgetsapplication/meson.build b/share/qtcreator/templates/wizards/projects/qtwidgetsapplication/meson.build
new file mode 100644
index 0000000000..c7a3ffd8e0
--- /dev/null
+++ b/share/qtcreator/templates/wizards/projects/qtwidgetsapplication/meson.build
@@ -0,0 +1,23 @@
+project('%{ProjectName}', 'cpp',default_options : ['cpp_std=c++11'])
+
+# Documentation: https://mesonbuild.com/Qt5-module.html
+qt5 = import('qt5')
+qt5dep = dependency('qt5', modules : ['Core', 'Widgets'])
+
+@if %{HasTranslation}
+translations = qt5.compile_translations(ts_files : '%{TsFileName}', build_by_default : true)
+@endif
+
+generated_files = qt5.preprocess(
+ moc_headers : '%{HdrFileName}',
+ @if %{GenerateForm}
+ ui_files : '%{FormFileName}',
+ @endif
+ dependencies: [qt5dep])
+
+executable('%{ProjectName}'
+ , '%{MainFileName}'
+ , '%{SrcFileName}'
+ , generated_files
+ , dependencies : [qt5dep]
+ , install : true)