aboutsummaryrefslogtreecommitdiffstats
path: root/src/libs/3rdparty/syntax-highlighting/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/libs/3rdparty/syntax-highlighting/CMakeLists.txt')
-rw-r--r--src/libs/3rdparty/syntax-highlighting/CMakeLists.txt11
1 files changed, 4 insertions, 7 deletions
diff --git a/src/libs/3rdparty/syntax-highlighting/CMakeLists.txt b/src/libs/3rdparty/syntax-highlighting/CMakeLists.txt
index 1304c1a004..ca0a039106 100644
--- a/src/libs/3rdparty/syntax-highlighting/CMakeLists.txt
+++ b/src/libs/3rdparty/syntax-highlighting/CMakeLists.txt
@@ -37,11 +37,8 @@ install(
DESTINATION "${IDE_DATA_PATH}/generic-highlighter/"
)
-add_custom_target(copy_generic_highligher_to_builddir ALL VERBATIM)
-add_custom_command(TARGET copy_generic_highligher_to_builddir POST_BUILD
- COMMAND "${CMAKE_COMMAND}" -E copy_directory data/syntax
- "${PROJECT_BINARY_DIR}/${IDE_DATA_PATH}/generic-highlighter/syntax"
- WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}"
- COMMENT Copy files into build directory
- VERBATIM
+# copy resource directories during build
+qtc_copy_to_builddir(copy_generic_highligher_to_builddir
+ DIRECTORIES data/syntax
+ DESTINATION "${IDE_DATA_PATH}/generic-highlighter/syntax"
)