aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/baremetal/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/baremetal/CMakeLists.txt')
-rw-r--r--src/plugins/baremetal/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/plugins/baremetal/CMakeLists.txt b/src/plugins/baremetal/CMakeLists.txt
new file mode 100644
index 0000000000..f9d9bc0dc5
--- /dev/null
+++ b/src/plugins/baremetal/CMakeLists.txt
@@ -0,0 +1,30 @@
+add_qtc_plugin(BareMetal
+ DEPENDS QtcSsh
+ PLUGIN_DEPENDS Core Debugger ProjectExplorer
+ SOURCES
+ baremetal.qrc
+ baremetalconstants.h
+ baremetalcustomrunconfiguration.cpp baremetalcustomrunconfiguration.h
+ baremetaldebugsupport.cpp baremetaldebugsupport.h
+ baremetaldevice.cpp baremetaldevice.h
+ baremetaldeviceconfigurationwidget.cpp baremetaldeviceconfigurationwidget.h
+ baremetaldeviceconfigurationwizard.cpp baremetaldeviceconfigurationwizard.h
+ baremetaldeviceconfigurationwizardpages.cpp baremetaldeviceconfigurationwizardpages.h
+ baremetalgdbcommandsdeploystep.cpp baremetalgdbcommandsdeploystep.h
+ baremetalplugin.cpp baremetalplugin.h
+ baremetalrunconfiguration.cpp baremetalrunconfiguration.h
+ defaultgdbserverprovider.cpp defaultgdbserverprovider.h
+ gdbserverprovider.cpp gdbserverprovider.h
+ gdbserverproviderchooser.cpp gdbserverproviderchooser.h
+ gdbserverprovidermanager.cpp gdbserverprovidermanager.h
+ gdbserverproviderprocess.cpp gdbserverproviderprocess.h
+ gdbserverproviderssettingspage.cpp gdbserverproviderssettingspage.h
+ iarewparser.cpp iarewparser.h
+ iarewtoolchain.cpp iarewtoolchain.h
+ keilparser.cpp keilparser.h
+ keiltoolchain.cpp keiltoolchain.h
+ sdccparser.cpp sdccparser.h
+ sdcctoolchain.cpp sdcctoolchain.h
+ openocdgdbserverprovider.cpp openocdgdbserverprovider.h
+ stlinkutilgdbserverprovider.cpp stlinkutilgdbserverprovider.h
+)