aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/clangformat/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/clangformat/CMakeLists.txt')
-rw-r--r--src/plugins/clangformat/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/plugins/clangformat/CMakeLists.txt b/src/plugins/clangformat/CMakeLists.txt
new file mode 100644
index 0000000000..3edaead757
--- /dev/null
+++ b/src/plugins/clangformat/CMakeLists.txt
@@ -0,0 +1,15 @@
+add_qtc_plugin(ClangFormat
+ CONDITION TARGET libclang
+ DEPENDS Utils Qt5::Widgets clangFormat
+ INCLUDES "${CLANG_INCLUDE_DIRS}"
+ PLUGIN_DEPENDS Core TextEditor CppEditor CppTools ProjectExplorer
+ SOURCES
+ clangformatbaseindenter.cpp clangformatbaseindenter.h
+ clangformatchecks.ui
+ clangformatconfigwidget.cpp clangformatconfigwidget.h clangformatconfigwidget.ui
+ clangformatconstants.h
+ clangformatindenter.cpp clangformatindenter.h
+ clangformatplugin.cpp clangformatplugin.h
+ clangformatsettings.cpp clangformatsettings.h
+ clangformatutils.cpp clangformatutils.h
+)