aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/clangrefactoring/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/clangrefactoring/CMakeLists.txt')
-rw-r--r--src/plugins/clangrefactoring/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/src/plugins/clangrefactoring/CMakeLists.txt b/src/plugins/clangrefactoring/CMakeLists.txt
new file mode 100644
index 0000000000..1e20afad9b
--- /dev/null
+++ b/src/plugins/clangrefactoring/CMakeLists.txt
@@ -0,0 +1,40 @@
+add_qtc_plugin(ClangRefactoring
+ CONDITION TARGET libclang
+ DEPENDS ClangSupport CPlusPlus
+ PLUGIN_DEPENDS Core CppTools TextEditor ClangPchManager
+ SOURCES ${TEST_SOURCES}
+ baseclangquerytexteditorwidget.cpp baseclangquerytexteditorwidget.h
+ clangqueryexamplehighlighter.cpp clangqueryexamplehighlighter.h
+ clangqueryexamplehighlightmarker.h
+ clangqueryexampletexteditorwidget.cpp clangqueryexampletexteditorwidget.h
+ clangqueryhighlighter.cpp clangqueryhighlighter.h
+ clangqueryhighlightmarker.h
+ clangqueryhoverhandler.cpp clangqueryhoverhandler.h
+ clangqueryprojectsfindfilter.cpp clangqueryprojectsfindfilter.h clangqueryprojectsfindfilter.ui
+ clangqueryprojectsfindfilterwidget.cpp clangqueryprojectsfindfilterwidget.h
+ clangquerytexteditorwidget.cpp clangquerytexteditorwidget.h
+ clangrefactoringplugin.cpp clangrefactoringplugin.h
+ editormanagerinterface.h
+ locatorfilter.cpp locatorfilter.h
+ projectpartproviderinterface.h
+ projectpartutilities.cpp projectpartutilities.h
+ qtcreatorclangqueryfindfilter.cpp qtcreatorclangqueryfindfilter.h
+ qtcreatoreditormanager.cpp qtcreatoreditormanager.h
+ qtcreatorrefactoringprojectupdater.cpp qtcreatorrefactoringprojectupdater.h
+ qtcreatorsearch.cpp qtcreatorsearch.h
+ qtcreatorsearchhandle.cpp qtcreatorsearchhandle.h
+ qtcreatorsymbolsfindfilter.cpp qtcreatorsymbolsfindfilter.h
+ querysqlitestatementfactory.h
+ refactoringclient.cpp refactoringclient.h
+ refactoringconnectionclient.cpp refactoringconnectionclient.h
+ refactoringengine.cpp refactoringengine.h
+ refactoringprojectupdater.cpp refactoringprojectupdater.h
+ searchhandle.cpp searchhandle.h
+ searchinterface.h
+ sourcelocations.h
+ symbol.h
+ symbolquery.h
+ symbolqueryinterface.h
+ symbolsfindfilter.cpp symbolsfindfilter.h
+ symbolsfindfilterconfigwidget.cpp symbolsfindfilterconfigwidget.h
+)