aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/nim/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/nim/CMakeLists.txt')
-rw-r--r--src/plugins/nim/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/src/plugins/nim/CMakeLists.txt b/src/plugins/nim/CMakeLists.txt
new file mode 100644
index 0000000000..ac450f76f4
--- /dev/null
+++ b/src/plugins/nim/CMakeLists.txt
@@ -0,0 +1,35 @@
+add_qtc_plugin(Nim
+ PLUGIN_DEPENDS Core TextEditor ProjectExplorer
+ SOURCES
+ editor/nimcompletionassistprovider.cpp editor/nimcompletionassistprovider.h
+ editor/nimeditorfactory.cpp editor/nimeditorfactory.h
+ editor/nimhighlighter.cpp editor/nimhighlighter.h
+ editor/nimindenter.cpp editor/nimindenter.h
+ nim.qrc
+ nimconstants.h
+ nimplugin.cpp nimplugin.h
+ project/nimbuildconfiguration.cpp project/nimbuildconfiguration.h
+ project/nimcompilerbuildstep.cpp project/nimcompilerbuildstep.h
+ project/nimcompilerbuildstepconfigwidget.cpp project/nimcompilerbuildstepconfigwidget.h project/nimcompilerbuildstepconfigwidget.ui
+ project/nimcompilercleanstep.cpp project/nimcompilercleanstep.h
+ project/nimcompilercleanstepconfigwidget.cpp project/nimcompilercleanstepconfigwidget.h project/nimcompilercleanstepconfigwidget.ui
+ project/nimproject.cpp project/nimproject.h
+ project/nimprojectnode.cpp project/nimprojectnode.h
+ project/nimrunconfiguration.cpp project/nimrunconfiguration.h
+ project/nimtoolchain.cpp project/nimtoolchain.h
+ project/nimtoolchainfactory.cpp project/nimtoolchainfactory.h
+ settings/nimcodestylepreferencesfactory.cpp settings/nimcodestylepreferencesfactory.h
+ settings/nimcodestylepreferenceswidget.cpp settings/nimcodestylepreferenceswidget.h settings/nimcodestylepreferenceswidget.ui
+ settings/nimcodestylesettingspage.cpp settings/nimcodestylesettingspage.h
+ settings/nimsettings.cpp settings/nimsettings.h
+ settings/nimtoolssettingspage.cpp settings/nimtoolssettingspage.h
+ settings/nimtoolssettingswidget.ui
+ suggest/client.cpp suggest/client.h
+ suggest/clientrequests.cpp suggest/clientrequests.h
+ suggest/nimsuggest.cpp suggest/nimsuggest.h
+ suggest/nimsuggestcache.cpp suggest/nimsuggestcache.h
+ suggest/server.cpp suggest/server.h
+ suggest/sexprlexer.h suggest/sexprparser.h
+ tools/nimlexer.cpp tools/nimlexer.h
+ tools/sourcecodestream.h
+)