aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/resourceeditor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/resourceeditor/CMakeLists.txt')
-rw-r--r--src/plugins/resourceeditor/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/plugins/resourceeditor/CMakeLists.txt b/src/plugins/resourceeditor/CMakeLists.txt
new file mode 100644
index 0000000000..e6d4003bf3
--- /dev/null
+++ b/src/plugins/resourceeditor/CMakeLists.txt
@@ -0,0 +1,16 @@
+add_qtc_plugin(ResourceEditor
+ DEPENDS Qt5::Xml
+ DEFINES RESOURCE_LIBRARY
+ PLUGIN_DEPENDS Core ProjectExplorer
+ SOURCES
+ qrceditor/qrceditor.cpp qrceditor/qrceditor.h qrceditor/qrceditor.ui
+ qrceditor/resourcefile.cpp qrceditor/resourcefile_p.h
+ qrceditor/resourceview.cpp qrceditor/resourceview.h
+ qrceditor/undocommands.cpp qrceditor/undocommands_p.h
+ resource_global.h
+ resourceeditorconstants.h
+ resourceeditorfactory.cpp resourceeditorfactory.h
+ resourceeditorplugin.cpp resourceeditorplugin.h
+ resourceeditorw.cpp resourceeditorw.h
+ resourcenode.cpp resourcenode.h
+)