summaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2022-02-04 18:37:51 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2022-02-05 01:34:43 +0100
commit0fc74dbb25e370f674a0292a30e87b468a6081c5 (patch)
treecbce5d721c9c526e692db6cfe33aa58759335fd1 /examples/CMakeLists.txt
parenta4e8e9ee31ee7b33bdd985dcff6556adc696d575 (diff)
Switch examples to build as isolated sub-builds part 2
qt_examples_build_begin needs the EXTERNAL_BUILD flag to know that it's safe to build examples as ExternalProjects. It still won't do it in CI until we enable building examples as ExternalProjects for prefix builds. This is preparation for that. Task-number: QTBUG-90820 Change-Id: Ifa72ee29d7515b585314caef47a0d8817910c186 Reviewed-by: Alexey Edelev <alexey.edelev@qt.io>
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 247cb4e..5b38096 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -1,6 +1,6 @@
# Generated from examples.pro.
-qt_examples_build_begin()
+qt_examples_build_begin(EXTERNAL_BUILD)
add_subdirectory(httpserver)