summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@nokia.com>2009-10-19 16:17:02 +0200
committerJoerg Bornemann <joerg.bornemann@nokia.com>2009-10-19 16:17:02 +0200
commita77b0346f5991e93a5a46155931d7bc4bec191e7 (patch)
tree3daf9095f384fc3f3e1d6966a50f9d1b388ba0a2 /CMakeLists.txt
parentfd7b0fe026a94d954d5f8e05d36bf04f82a3cede (diff)
build fix when using cmake
We must call cl with /Zc:wchar_t-
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4b0dfaf..a9befdc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,6 +29,8 @@ if(MSVC)
if(CMAKE_BUILD_TYPE STREQUAL Debug)
set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /NODEFAULTLIB:MSVCRT")
endif(CMAKE_BUILD_TYPE STREQUAL Debug)
+
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /Zc:wchar_t-")
endif(MSVC)