summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5021051..6fbafa6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,15 +21,12 @@ include_directories(
)
if(MSVC)
add_definitions(
- -D_CRT_SECURE_NO_DEPRECATE
+ -D_CRT_SECURE_NO_WARNINGS
)
- # Qt disables the native wchar_t type, do it too to avoid linking issues
- set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Zc:wchar_t-" )
endif(MSVC)
add_definitions(
+ -DQT_NO_CAST_FROM_ASCII
-DQT_NO_CAST_TO_ASCII
- -DQT_USE_FAST_CONCATENATION
- -DQT_USE_FAST_OPERATOR_PLUS
-DUNICODE
)