aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEskil Abrahamsen Blomfeldt <eskil.abrahamsen-blomfeldt@qt.io>2021-04-28 10:32:02 +0200
committerEskil Abrahamsen Blomfeldt <eskil.abrahamsen-blomfeldt@qt.io>2021-04-28 12:42:45 +0000
commit4bf0cd983c2620fb7c3168e00317dc17123b0615 (patch)
tree54840229bd8325ff9f54b65638dfc420b45309ee /CMakeLists.txt
parentac368f6062804305b2257df80fe72923d413e4ad (diff)
Make sure default surface format supports Qt Quick 3D
We need to pick an appropriate OpenGL version in order to support all the QQ3D benchmarks. This also means we have to move the setup for the surface format until after initializing the GUI application, but having this before is not actually needed in our case anyway. Change-Id: I98ad3399b0a00aba7252f4c8b646a073c8ec1584 Reviewed-by: Laszlo Agocs <laszlo.agocs@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 015bc14..dcf53a0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,7 +16,7 @@ project(QMLBench
set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
# special case end
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Qml Quick Test)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Qml Quick Test Quick3D)
qt_build_repo_begin()