aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Smith <daniel.smith@qt.io>2020-11-26 11:00:02 +0100
committerDaniel Smith <Daniel.Smith@qt.io>2020-11-26 12:38:03 +0000
commit949ad29539b29feb12001f7d5e5997c6f3a43fed (patch)
tree6ba2bb2e69564cbf93367914ccc30090c2792fcd /CMakeLists.txt
parent13bb5aa8ead23a6bdef33a85b5907e108777526a (diff)
Add CMakeLists
Add support for building qmlbench with CMake Change-Id: I85fd6ec6ef39beed8a8e067e121ddbca29b50bad Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..015bc14
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Generated from qmlbench.pro.
+# special case skip regeneration
+
+cmake_minimum_required(VERSION 3.15.0)
+
+include(.cmake.conf)
+project(QMLBench
+ VERSION "${QT_REPO_MODULE_VERSION}"
+ DESCRIPTION "QMLBench" # special case
+ HOMEPAGE_URL "https://qt.io/"
+ LANGUAGES CXX C
+)
+
+# special case begin
+# Make sure we only use latest private CMake API, aka no compatibility wrappers.
+set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
+# special case end
+
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Qml Quick Test)
+
+qt_build_repo_begin()
+
+add_subdirectory(src)
+add_subdirectory(tools)
+
+qt_build_repo_end()
+