aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qtlicensetool/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qtlicensetool/CMakeLists.txt')
-rw-r--r--tests/auto/qtlicensetool/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/auto/qtlicensetool/CMakeLists.txt b/tests/auto/qtlicensetool/CMakeLists.txt
new file mode 100644
index 0000000..47ba939
--- /dev/null
+++ b/tests/auto/qtlicensetool/CMakeLists.txt
@@ -0,0 +1,13 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+#
+# Published under GPL-3.0 with Qt-GPL-exception-1.0
+#
+
+include_directories(${CMAKE_CURRENT_LIST_DIR}/../../../src/qtlicensetool/)
+
+list(APPEND extSrc ${CMAKE_CURRENT_LIST_DIR}/../../../src/qtlicensetool/qtlicensetool.cpp)
+
+add_executable(tst_qtlicensetool ${extSrc} tst_qtlicensetool.cpp)
+target_link_libraries(tst_qtlicensetool PRIVATE Catch2 qlicenseservice)
+
+add_test(NAME tst_qtlicensetool COMMAND tst_qtlicensetool)