summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/phonon/ds9/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rdparty/phonon/ds9/CMakeLists.txt')
-rw-r--r--src/3rdparty/phonon/ds9/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/3rdparty/phonon/ds9/CMakeLists.txt b/src/3rdparty/phonon/ds9/CMakeLists.txt
index 1bb6f6f79d..7378b53110 100644
--- a/src/3rdparty/phonon/ds9/CMakeLists.txt
+++ b/src/3rdparty/phonon/ds9/CMakeLists.txt
@@ -40,14 +40,15 @@ if (BUILD_PHONON_DS9)
)
add_definitions(-DPHONON_MAKE_QT_ONLY_BACKEND -DUNICODE)
- automoc4_add_library(phonon_ds9 SHARED ${phonon_ds9_SRCS})
+ automoc4_add_library(phonon_ds9 MODULE ${phonon_ds9_SRCS})
set_target_properties(phonon_ds9 PROPERTIES PREFIX "")
target_link_libraries(phonon_ds9
${PHONON_LIBS} ${QT_QTOPENGL_LIBRARY} ${OPENGL_gl_LIBRARY}
dxguid strmiids dmoguids msdmo ole32 oleaut32 uuid gdi32)
+ # 'MODULE' is treated as a LIBRARY
install(TARGETS phonon_ds9
RUNTIME DESTINATION ${BIN_INSTALL_DIR}/phonon_backend
- LIBRARY DESTINATION ${LIB_INSTALL_DIR}
+ LIBRARY DESTINATION ${BIN_INSTALL_DIR}/phonon_backend
ARCHIVE DESTINATION ${LIB_INSTALL_DIR})
install(FILES ds9.desktop DESTINATION ${SERVICES_INSTALL_DIR}/phononbackends)
endif (BUILD_PHONON_DS9)