summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-05-18 15:27:48 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-06-04 15:43:42 +0200
commitc1ae8a2812349a2254b3c4a4a4eea23db5567302 (patch)
tree4079c8c65d2d8bf5fc93b0f8d35efe980f20766c /CMakeLists.txt
parentceb1dfb6264eb5f5ee7cac093d7c878eb59196a4 (diff)
Use fixed qt_add_resource BASE argument
Task-number: QTBUG-86726 Change-Id: I2a7748b67b55008962809ece1a34c6cf2a0617bb Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cc3e925c9..35a6fafb6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,6 +14,9 @@ project(Qt3D # special case
# Make sure we only use latest private CMake API, aka no compatibility wrappers.
set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
+# Make sure we use the fixed BASE argument of qt_add_resource.
+set(QT_USE_FIXED_QT_ADD_RESOURCE_BASE TRUE)
+
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS
Concurrent Widgets Qml Quick Gamepad OpenGL ShaderTools)