summaryrefslogtreecommitdiffstats
path: root/src/quick3d/imports/logic/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-04-15 12:40:07 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2021-04-15 14:54:55 +0200
commitd1bd4d78d7361f5d909be3184ce8bab8c5417945 (patch)
tree61a75a755e4e650c5d51b994fb5016aa47397365 /src/quick3d/imports/logic/CMakeLists.txt
parent04a3129c52b64d4c53b7a13cc525a38153e3eca1 (diff)
CMake: Fix qml module version to use the repo project version
Use PROJECT_VERSION instead of CMAKE_PROJECT_VERSION, so that the repo project version is used in a top-level build, rather than the version of the qt5 project. Pick-to: 6.1 6.0 Task-number: QTBUG-92861 Change-Id: I94ff185cf5f37b19959e620921b9c97fde1bfc07 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'src/quick3d/imports/logic/CMakeLists.txt')
-rw-r--r--src/quick3d/imports/logic/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/quick3d/imports/logic/CMakeLists.txt b/src/quick3d/imports/logic/CMakeLists.txt
index 9cf595ab9..2d7b5ea9b 100644
--- a/src/quick3d/imports/logic/CMakeLists.txt
+++ b/src/quick3d/imports/logic/CMakeLists.txt
@@ -6,7 +6,7 @@
qt_internal_add_qml_module(quick3dlogicplugin
URI "Qt3D.Logic"
- VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ VERSION "2.${PROJECT_VERSION_MINOR}"
CLASSNAME Qt3DQuick3DLogicPlugin
SKIP_TYPE_REGISTRATION
SOURCES