summaryrefslogtreecommitdiffstats
path: root/src/quick3d/imports/scene3d/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Krus <mike.krus@kdab.com>2020-06-17 11:52:02 +0100
committerMike Krus <mike.krus@kdab.com>2020-06-18 11:49:03 +0100
commiteebbdb87b255545c83038aa4ff422e7ef34c3f6e (patch)
tree7a2b294a37d8de3c80f91fa153782c2bed424830 /src/quick3d/imports/scene3d/CMakeLists.txt
parentb9994cd88925ca012d66e52d033cc9a3a909fc7a (diff)
Handle config flags to turn aspects on or off
Also restores RHI option but it's off by default. Moved render module config to renderer plugin folder as those are the only options for now. Change-Id: Ie102e5b9365b3bea8f4bc97cb76b3a19851b1fa5 Reviewed-by: Paul Lemire <paul.lemire@kdab.com>
Diffstat (limited to 'src/quick3d/imports/scene3d/CMakeLists.txt')
-rw-r--r--src/quick3d/imports/scene3d/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/quick3d/imports/scene3d/CMakeLists.txt b/src/quick3d/imports/scene3d/CMakeLists.txt
index 7c318754f..a658714a2 100644
--- a/src/quick3d/imports/scene3d/CMakeLists.txt
+++ b/src/quick3d/imports/scene3d/CMakeLists.txt
@@ -45,7 +45,7 @@ qt_extend_target(qtquickscene3dplugin CONDITION QT_FEATURE_qt3d_input
qt_extend_target(qtquickscene3dplugin CONDITION QT_FEATURE_qt3d_logic
PUBLIC_LIBRARIES
- 3DLogic
+ Qt::3DLogic
)
qt_extend_target(qtquickscene3dplugin CONDITION QT_FEATURE_qt3d_animation