summaryrefslogtreecommitdiffstats
path: root/tests/auto/input/physicaldeviceproxy/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Krus <mike.krus@kdab.com>2020-05-08 14:06:53 +0100
committerMike Krus <mike.krus@kdab.com>2020-05-22 08:53:50 +0100
commit22dd30949938083aceda8267c41c920c61c0d388 (patch)
treea49704414a853624006b860d1a92689bc4f5ca88 /tests/auto/input/physicaldeviceproxy/CMakeLists.txt
parent5596989f92fd36615e203215ef274bff80bb7e31 (diff)
Add support for building with CMake
Change-Id: If6c887c6356a160a5f3fb906d38a341fff0c7b29 Reviewed-by: Mike Krus <mike.krus@kdab.com>
Diffstat (limited to 'tests/auto/input/physicaldeviceproxy/CMakeLists.txt')
-rw-r--r--tests/auto/input/physicaldeviceproxy/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/auto/input/physicaldeviceproxy/CMakeLists.txt b/tests/auto/input/physicaldeviceproxy/CMakeLists.txt
new file mode 100644
index 000000000..286402eda
--- /dev/null
+++ b/tests/auto/input/physicaldeviceproxy/CMakeLists.txt
@@ -0,0 +1,34 @@
+# Generated from physicaldeviceproxy.pro.
+
+#####################################################################
+## tst_physicaldeviceproxy Test:
+#####################################################################
+
+qt_add_test(tst_physicaldeviceproxy
+ SOURCES
+ ../commons/testdevice.h
+ ../commons/testdeviceproxy.h
+ tst_physicaldeviceproxy.cpp
+ INCLUDE_DIRECTORIES
+ ../../core/common
+ ../commons
+ PUBLIC_LIBRARIES
+ Qt::3DCore
+ Qt::3DCorePrivate
+ Qt::3DInput
+ Qt::3DInputPrivate
+ Qt::CorePrivate
+ Qt::Gui
+)
+
+#### Keys ignored in scope 1:.:.:physicaldeviceproxy.pro:<TRUE>:
+# TEMPLATE = "app"
+
+## Scopes:
+#####################################################################
+
+qt_extend_target(tst_physicaldeviceproxy CONDITION QT_FEATURE_private_tests
+ SOURCES
+ ../../core/common/qbackendnodetester.cpp ../../core/common/qbackendnodetester.h
+ ../../core/common/testarbiter.h
+)