summaryrefslogtreecommitdiffstats
path: root/tests/auto/quick3d/quick3dnodeinstantiator/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Krus <mike.krus@kdab.com>2020-05-08 14:06:53 +0100
committerMike Krus <mike.krus@kdab.com>2020-05-22 08:53:50 +0100
commit22dd30949938083aceda8267c41c920c61c0d388 (patch)
treea49704414a853624006b860d1a92689bc4f5ca88 /tests/auto/quick3d/quick3dnodeinstantiator/CMakeLists.txt
parent5596989f92fd36615e203215ef274bff80bb7e31 (diff)
Add support for building with CMake
Change-Id: If6c887c6356a160a5f3fb906d38a341fff0c7b29 Reviewed-by: Mike Krus <mike.krus@kdab.com>
Diffstat (limited to 'tests/auto/quick3d/quick3dnodeinstantiator/CMakeLists.txt')
-rw-r--r--tests/auto/quick3d/quick3dnodeinstantiator/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/tests/auto/quick3d/quick3dnodeinstantiator/CMakeLists.txt b/tests/auto/quick3d/quick3dnodeinstantiator/CMakeLists.txt
new file mode 100644
index 000000000..f79d97d2e
--- /dev/null
+++ b/tests/auto/quick3d/quick3dnodeinstantiator/CMakeLists.txt
@@ -0,0 +1,36 @@
+# Generated from quick3dnodeinstantiator.pro.
+
+#####################################################################
+## tst_qnodeinstantiator Test:
+#####################################################################
+
+# Collect test data
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ data/*)
+list(APPEND test_data ${test_data_glob})
+
+qt_add_test(tst_qnodeinstantiator
+ SOURCES
+ ../../shared/util.cpp ../../shared/util.h
+ stringmodel.h
+ tst_quick3dnodeinstantiator.cpp
+ DEFINES
+ QT_QMLTEST_DATADIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/data\\\"
+ INCLUDE_DIRECTORIES
+ ../../shared
+ PUBLIC_LIBRARIES
+ Qt::3DCore
+ Qt::3DQuick
+ Qt::3DQuickPrivate
+ Qt::CorePrivate
+ Qt::Gui
+ Qt::GuiPrivate
+ TESTDATA ${test_data}
+)
+
+#### Keys ignored in scope 1:.:.:quick3dnodeinstantiator.pro:<TRUE>:
+# OTHER_FILES = "data/createAndRemove.qml" "data/createMultiple.qml" "data/createNone.qml" "data/createSingle.qml" "data/createNested.qml" "data/inactive.qml" "data/stringModel.qml"
+
+## Scopes:
+#####################################################################