summaryrefslogtreecommitdiffstats
path: root/tests/auto/render/CMakeLists.txt
diff options
context:
space:
mode:
authorThiago Macieira <thiago.macieira@intel.com>2022-11-23 12:37:00 -0800
committerThiago Macieira <thiago.macieira@intel.com>2023-01-19 19:18:52 -0800
commit00cb8afafb2867b348aa529c0702252d12d1b4d6 (patch)
treee173cbc730f713f44aaeaf399383617493549329 /tests/auto/render/CMakeLists.txt
parent15e4fc5daeeec5eeb0c1ccb0ce6f76b5b284e2c7 (diff)
3DCore: rip away the configure option and static choice of SIMD
Instead, simply use whatever is available from the compiler. This also does away with the separation between Matrix4x4_SSE and Matrix4x4_AVX2. The two classes store the data the same way and are source-compatible; they just operate differently. This also allows for an AVX2-enabled Qt3DRenderer to link to and run with a non-AVX Qt3DCore. Change-Id: I76216ced393445a4ae2dfffd172a512266b2414d Reviewed-by: Paul Lemire <paul.lemire@kdab.com>
Diffstat (limited to 'tests/auto/render/CMakeLists.txt')
-rw-r--r--tests/auto/render/CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/tests/auto/render/CMakeLists.txt b/tests/auto/render/CMakeLists.txt
index c5c68a081..9285364f2 100644
--- a/tests/auto/render/CMakeLists.txt
+++ b/tests/auto/render/CMakeLists.txt
@@ -108,8 +108,6 @@ if(QT_FEATURE_private_tests)
add_subdirectory(uniform)
add_subdirectory(vsyncframeadvanceservice)
add_subdirectory(waitfence)
-endif()
-if(QT_FEATURE_private_tests AND NOT QT_FEATURE_qt3d_simd_avx2)
add_subdirectory(qray3d)
add_subdirectory(raycasting)
add_subdirectory(triangleboundingvolume)
@@ -143,9 +141,7 @@ if(QT_FEATURE_private_tests AND QT_FEATURE_qt3d_input AND QT_FEATURE_qt3d_opengl
add_subdirectory(qscene2d)
add_subdirectory(scene2d)
endif()
-if(QT_FEATURE_private_tests AND QT_FEATURE_qt3d_opengl_renderer AND QT_FEATURE_qt3d_simd_avx2)
- add_subdirectory(alignedresourcesmanagers-avx)
-endif()
-if(QT_FEATURE_private_tests AND QT_FEATURE_qt3d_opengl_renderer AND QT_FEATURE_qt3d_simd_sse2 AND NOT QT_FEATURE_qt3d_simd_avx2)
+if(QT_FEATURE_private_tests AND NOT (CMAKE_OSX_ARCHITECTURES MATCHES ";") AND
+ (TEST_architecture_arch STREQUAL i386 OR TEST_architecture_arch STREQUAL x86_64))
add_subdirectory(alignedresourcesmanagers-sse)
endif()