summaryrefslogtreecommitdiffstats
path: root/tests/auto/render/qgeometryrenderer/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2023-07-05 17:45:34 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2023-07-06 18:39:04 +0200
commit5943d24770bfb4eb9ccde8b56259793957eb33c5 (patch)
tree0c1e19bf656cd8a5505e4ad430b3a7a98bab06ed /tests/auto/render/qgeometryrenderer/CMakeLists.txt
parentd5e63a75d1a83a7ac8889f1a15a9cd234c812b4a (diff)
CMake: Make qt3d tests standalone projects
Add the boilerplate standalone test prelude to each test, so that they can be opened with an IDE without the qt-cmake-standalone-test script, but directly with qt-cmake or cmake. Boilerplate was added using the following scripts: https://git.qt.io/alcroito/cmake_refactor Manual adjustments were made where the code was inserted in the wrong location. render/opengl tests were omitted because they include other files that make the tests non-standalone. Task-number: QTBUG-93020 Change-Id: I3c7e2ca8dafc15acfe909aad3fa60300ac9db525 Reviewed-by: Alexey Edelev <alexey.edelev@qt.io>
Diffstat (limited to 'tests/auto/render/qgeometryrenderer/CMakeLists.txt')
-rw-r--r--tests/auto/render/qgeometryrenderer/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/auto/render/qgeometryrenderer/CMakeLists.txt b/tests/auto/render/qgeometryrenderer/CMakeLists.txt
index 6160d7958..82b5c03b9 100644
--- a/tests/auto/render/qgeometryrenderer/CMakeLists.txt
+++ b/tests/auto/render/qgeometryrenderer/CMakeLists.txt
@@ -7,6 +7,12 @@
## tst_qgeometryrenderer Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qgeometryrenderer LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qgeometryrenderer
SOURCES
tst_qgeometryrenderer.cpp