summaryrefslogtreecommitdiffstats
path: root/examples/qt3d/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qt3d/CMakeLists.txt')
-rw-r--r--examples/qt3d/CMakeLists.txt19
1 files changed, 1 insertions, 18 deletions
diff --git a/examples/qt3d/CMakeLists.txt b/examples/qt3d/CMakeLists.txt
index 01c642ee6..6041bdcda 100644
--- a/examples/qt3d/CMakeLists.txt
+++ b/examples/qt3d/CMakeLists.txt
@@ -1,37 +1,20 @@
# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
qt_internal_add_example(3d-text)
qt_internal_add_example(simple-cpp)
if(TARGET Qt::Widgets)
qt_internal_add_example(basicshapes-cpp)
endif()
-if(TARGET Qt::QuickWidgets AND TARGET Qt::Widgets)
- qt_internal_add_example(widgets-scene3d)
-endif()
if(TARGET Qt::Quick)
- qt_internal_add_example(advancedcustommaterial)
- qt_internal_add_example(compute-particles)
qt_internal_add_example(controls)
- qt_internal_add_example(controlsunderlay)
qt_internal_add_example(instanced-arrays-qml)
qt_internal_add_example(multiviewport)
- qt_internal_add_example(planets-qml)
-# qt_internal_add_example(scene2d) # Restore once Scene2D support has been ported to Qt6
- qt_internal_add_example(scene3d)
qt_internal_add_example(simple-qml)
qt_internal_add_example(simplecustommaterial)
- qt_internal_add_example(wave)
# these require qt6_add_big_resources but it's broken at this point QTBUG-85051
-# qt_internal_add_example(anaglyph-rendering)
# qt_internal_add_example(lights)
# qt_internal_add_example(pbr-materials)
-# qt_internal_add_example(phong-cubes)
-# qt_internal_add_example(qardboard)
-# qt_internal_add_example(shadow-map-qml)
# qt_internal_add_example(wireframe)
endif()
-if(TARGET Qt::Multimedia AND TARGET Qt::Quick)
-# qt_internal_add_example(audio-visualizer-qml)
-endif()