summaryrefslogtreecommitdiffstats
path: root/examples/qt3d/lights/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qt3d/lights/CMakeLists.txt')
-rw-r--r--examples/qt3d/lights/CMakeLists.txt38
1 files changed, 2 insertions, 36 deletions
diff --git a/examples/qt3d/lights/CMakeLists.txt b/examples/qt3d/lights/CMakeLists.txt
index 2ff727721..9606bc369 100644
--- a/examples/qt3d/lights/CMakeLists.txt
+++ b/examples/qt3d/lights/CMakeLists.txt
@@ -74,43 +74,9 @@ qt6_add_resources(lights "obj"
FILES
${obj_resource_files}
)
-set(textures_resource_files
- "../exampleresources/assets/textures/aluminium_random_brushed/aluminium_random_brushed_basecolor.png"
- "../exampleresources/assets/textures/aluminium_random_brushed/aluminium_random_brushed_metallic.png"
- "../exampleresources/assets/textures/aluminium_random_brushed/aluminium_random_brushed_normal.png"
- "../exampleresources/assets/textures/aluminium_random_brushed/aluminium_random_brushed_roughness.png"
- "../exampleresources/assets/textures/american_walnut_crown_cut/american_walnut_crown_cut_basecolor.png"
- "../exampleresources/assets/textures/american_walnut_crown_cut/american_walnut_crown_cut_metallic.png"
- "../exampleresources/assets/textures/american_walnut_crown_cut/american_walnut_crown_cut_normal.png"
- "../exampleresources/assets/textures/american_walnut_crown_cut/american_walnut_crown_cut_roughness.png"
- "../exampleresources/assets/textures/ceramic_small_diamond/ceramic_small_diamond_ambient_occlusion.png"
- "../exampleresources/assets/textures/ceramic_small_diamond/ceramic_small_diamond_basecolor.png"
- "../exampleresources/assets/textures/ceramic_small_diamond/ceramic_small_diamond_metallic.png"
- "../exampleresources/assets/textures/ceramic_small_diamond/ceramic_small_diamond_normal.png"
- "../exampleresources/assets/textures/ceramic_small_diamond/ceramic_small_diamond_roughness.png"
- "../exampleresources/assets/textures/ceramic_tiles_brown_tomato/ceramic_tiles_brown_tomato_basecolor.png"
- "../exampleresources/assets/textures/ceramic_tiles_brown_tomato/ceramic_tiles_brown_tomato_metallic.png"
- "../exampleresources/assets/textures/ceramic_tiles_brown_tomato/ceramic_tiles_brown_tomato_normal.png"
- "../exampleresources/assets/textures/ceramic_tiles_brown_tomato/ceramic_tiles_brown_tomato_roughness.png"
- "../exampleresources/assets/textures/copper_brushed/copper_brushed_basecolor.png"
- "../exampleresources/assets/textures/copper_brushed/copper_brushed_metallic.png"
- "../exampleresources/assets/textures/copper_brushed/copper_brushed_normal.png"
- "../exampleresources/assets/textures/copper_brushed/copper_brushed_roughness.png"
- "../exampleresources/assets/textures/gold_leaf_waste/gold_leaf_waste_basecolor.png"
- "../exampleresources/assets/textures/gold_leaf_waste/gold_leaf_waste_metallic.png"
- "../exampleresources/assets/textures/gold_leaf_waste/gold_leaf_waste_normal.png"
- "../exampleresources/assets/textures/gold_leaf_waste/gold_leaf_waste_roughness.png"
- "../exampleresources/assets/textures/no-ao.png"
-)
-qt6_add_resources(lights "textures"
- PREFIX
- "/"
- BASE
- "../exampleresources"
- FILES
- ${textures_resource_files}
-)
+qt6_add_big_resources(big_resources ../exampleresources/textures.qrc)
+target_sources(lights PRIVATE ${big_resources})
install(TARGETS lights
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"