summaryrefslogtreecommitdiffstats
path: root/tests/auto/animation/clipblendnodemanager/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/animation/clipblendnodemanager/CMakeLists.txt')
-rw-r--r--tests/auto/animation/clipblendnodemanager/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/auto/animation/clipblendnodemanager/CMakeLists.txt b/tests/auto/animation/clipblendnodemanager/CMakeLists.txt
index 70bc9490b..611a1f3e1 100644
--- a/tests/auto/animation/clipblendnodemanager/CMakeLists.txt
+++ b/tests/auto/animation/clipblendnodemanager/CMakeLists.txt
@@ -7,6 +7,12 @@
## tst_clipblendnodemanager Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_clipblendnodemanager LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_clipblendnodemanager
SOURCES
tst_clipblendnodemanager.cpp