summaryrefslogtreecommitdiffstats
path: root/tests/auto/animation/qabstractanimation/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/animation/qabstractanimation/CMakeLists.txt')
-rw-r--r--tests/auto/animation/qabstractanimation/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/auto/animation/qabstractanimation/CMakeLists.txt b/tests/auto/animation/qabstractanimation/CMakeLists.txt
index 520c4f0db..2b39723d3 100644
--- a/tests/auto/animation/qabstractanimation/CMakeLists.txt
+++ b/tests/auto/animation/qabstractanimation/CMakeLists.txt
@@ -7,6 +7,11 @@
## tst_qabstractanimation Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qt3d_qabstractanimation LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
# special case begin
qt_internal_add_test(tst_qt3d_qabstractanimation