summaryrefslogtreecommitdiffstats
path: root/tests/auto/animation/qvertexblendanimation/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/animation/qvertexblendanimation/CMakeLists.txt')
-rw-r--r--tests/auto/animation/qvertexblendanimation/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/auto/animation/qvertexblendanimation/CMakeLists.txt b/tests/auto/animation/qvertexblendanimation/CMakeLists.txt
index f0d82c0d1..d08326c13 100644
--- a/tests/auto/animation/qvertexblendanimation/CMakeLists.txt
+++ b/tests/auto/animation/qvertexblendanimation/CMakeLists.txt
@@ -7,6 +7,12 @@
## tst_qvertexblendanimation Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qvertexblendanimation LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qvertexblendanimation
SOURCES
tst_qvertexblendanimation.cpp