summaryrefslogtreecommitdiffstats
path: root/tests/auto/core/vector4d_base/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/core/vector4d_base/CMakeLists.txt')
-rw-r--r--tests/auto/core/vector4d_base/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/auto/core/vector4d_base/CMakeLists.txt b/tests/auto/core/vector4d_base/CMakeLists.txt
index 1c7fb65bd..57f4cb774 100644
--- a/tests/auto/core/vector4d_base/CMakeLists.txt
+++ b/tests/auto/core/vector4d_base/CMakeLists.txt
@@ -7,6 +7,12 @@
## tst_vector4d_base Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_vector4d_base LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_vector4d_base
SOURCES
tst_vector4d_base.cpp