summaryrefslogtreecommitdiffstats
path: root/tests/auto/input/qabstractphysicaldeviceproxy/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/input/qabstractphysicaldeviceproxy/CMakeLists.txt')
-rw-r--r--tests/auto/input/qabstractphysicaldeviceproxy/CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/tests/auto/input/qabstractphysicaldeviceproxy/CMakeLists.txt b/tests/auto/input/qabstractphysicaldeviceproxy/CMakeLists.txt
index e1d6aac23..c6b4834c2 100644
--- a/tests/auto/input/qabstractphysicaldeviceproxy/CMakeLists.txt
+++ b/tests/auto/input/qabstractphysicaldeviceproxy/CMakeLists.txt
@@ -1,18 +1,28 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from qabstractphysicaldeviceproxy.pro.
#####################################################################
## tst_qabstractphysicaldeviceproxy Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qabstractphysicaldeviceproxy LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qabstractphysicaldeviceproxy
SOURCES
../commons/testdevice.h
+ ../commons/testdevice.cpp
../commons/testdeviceproxy.h
tst_qabstractphysicaldeviceproxy.cpp
INCLUDE_DIRECTORIES
../../core/common
../commons
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::3DCore
Qt::3DCorePrivate
Qt::3DInput