summaryrefslogtreecommitdiffstats
path: root/tests/auto/render/qproximityfilter/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/render/qproximityfilter/CMakeLists.txt')
-rw-r--r--tests/auto/render/qproximityfilter/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/auto/render/qproximityfilter/CMakeLists.txt b/tests/auto/render/qproximityfilter/CMakeLists.txt
index ef71898ef..b453a6eb8 100644
--- a/tests/auto/render/qproximityfilter/CMakeLists.txt
+++ b/tests/auto/render/qproximityfilter/CMakeLists.txt
@@ -7,6 +7,12 @@
## tst_qproximityfilter Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qproximityfilter LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qproximityfilter
SOURCES
tst_qproximityfilter.cpp