summaryrefslogtreecommitdiffstats
path: root/tests/manual/rendertarget-cpp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/rendertarget-cpp/CMakeLists.txt')
-rw-r--r--tests/manual/rendertarget-cpp/CMakeLists.txt45
1 files changed, 16 insertions, 29 deletions
diff --git a/tests/manual/rendertarget-cpp/CMakeLists.txt b/tests/manual/rendertarget-cpp/CMakeLists.txt
index 5fa98149b..97cfb0fe9 100644
--- a/tests/manual/rendertarget-cpp/CMakeLists.txt
+++ b/tests/manual/rendertarget-cpp/CMakeLists.txt
@@ -1,34 +1,21 @@
# Generated from rendertarget-cpp.pro.
-cmake_minimum_required(VERSION 3.14)
-project(rendertarget-cpp LANGUAGES CXX)
+#####################################################################
+## rendertarget-cpp Binary:
+#####################################################################
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-set(INSTALL_EXAMPLEDIR "examples")
-
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-
-add_qt_gui_executable(rendertarget-cpp
- main.cpp
- orbittransformcontroller.cpp orbittransformcontroller.h
-)
-target_link_libraries(rendertarget-cpp PUBLIC
- Qt::3DCore
- Qt::3DExtras
- Qt::3DInput
- Qt::3DRender
- Qt::Core
- Qt::Gui
+qt_add_manual_test(rendertarget-cpp
+ GUI
+ SOURCES
+ main.cpp
+ orbittransformcontroller.cpp orbittransformcontroller.h
+ PUBLIC_LIBRARIES
+ Qt::3DCore
+ Qt::3DExtras
+ Qt::3DInput
+ Qt::3DRender
+ Qt::Gui
)
-install(TARGETS rendertarget-cpp
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)
+## Scopes:
+#####################################################################