summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiang Qi <liang.qi@qt.io>2019-12-06 10:25:21 +0100
committerLiang Qi <liang.qi@qt.io>2019-12-06 10:25:21 +0100
commit2d6f569ee9d66ff49ab803ad9c48a954e637e1da (patch)
tree502f17abd3a89f715b7bf136f896f7d3601490ca
parent0d6ae070f44236fdceda6241e9564dba93c91d0b (diff)
parent4282752c1993420d0ab1c21c5dad01679cf18365 (diff)
Merge remote-tracking branch 'origin/5.15' into dev
-rwxr-xr-xcoin/provisioning/common/shared/testserver/docker_images.sh14
-rwxr-xr-xcoin/provisioning/common/unix/python_modules.sh4
-rwxr-xr-xcoin/provisioning/common/unix/squishInstall.sh8
-rw-r--r--coin/provisioning/common/windows/squishInstall.ps110
-rwxr-xr-xcoin/provisioning/qtci-linux-Ubuntu-18.04-x86_64/02-apt.sh2
5 files changed, 19 insertions, 19 deletions
diff --git a/coin/provisioning/common/shared/testserver/docker_images.sh b/coin/provisioning/common/shared/testserver/docker_images.sh
index e98183d8..1d467f7b 100755
--- a/coin/provisioning/common/shared/testserver/docker_images.sh
+++ b/coin/provisioning/common/shared/testserver/docker_images.sh
@@ -51,18 +51,20 @@ sha1tree () {
sort | ${SHASUM-sha1sum} | cut -d ' ' -f 1
}
-# Using SHA-1 of each server context as the tag of docker images. A tag labels a
-# specific image version. It is used by docker compose file (docker-compose.yml)
-# to launch the corresponding docker containers. If one of the server contexts
-# (./apache2, ./danted, ...) gets changes, all the related compose files in
-# qtbase should be updated as well.
+# A tag labels a specific image version. In the docker compose file
+# (docker-compose.yml) that launches the containers, the tag used is
+# "latest". Here the images are also tagged with the SHA1 of each server
+# context, so if needed we can modify docker-compose.yml to launch a very
+# specific image, thus providing a way to stage backwards-incompatible changes
+# across repositories.
source "$SERVER_PATH/settings.sh"
for server in $testserver
do
context="$SERVER_PATH/$server"
- docker build -t qt-test-server-$server:$(sha1tree $context) $context
+ tag=$(sha1tree $context)
+ docker build -t qt-test-server-$server:$tag -t qt-test-server-$server:latest $context
done
docker images
diff --git a/coin/provisioning/common/unix/python_modules.sh b/coin/provisioning/common/unix/python_modules.sh
index dbf26a85..89adbd5c 100755
--- a/coin/provisioning/common/unix/python_modules.sh
+++ b/coin/provisioning/common/unix/python_modules.sh
@@ -34,5 +34,5 @@
#############################################################################
# needed by packaging scripts
-sudo pip3 install bs4
-sudo pip3 install sh
+pip3 install bs4
+pip3 install sh
diff --git a/coin/provisioning/common/unix/squishInstall.sh b/coin/provisioning/common/unix/squishInstall.sh
index f1b5e6b5..24a4d507 100755
--- a/coin/provisioning/common/unix/squishInstall.sh
+++ b/coin/provisioning/common/unix/squishInstall.sh
@@ -38,14 +38,14 @@ set -ex
# This script will install squish package for Linux and Mac.
# Squish is need by Release Test Automation (RTA)
-version="6.4.3"
+version="6.5"
# Branch version without dot
-qtBranch="512x"
+qtBranch="513x"
squishFolder="/opt/squish"
squishUrl="ci-files01-hki.intra.qt.io:/hdd/www/input/squish/coin/$qtBranch/"
-squishFile="squish-$version-qt$qtBranch-linux64.run"
+squishFile="squish-nosignalhandler-$version-qt$qtBranch-linux64.run"
if uname -a |grep -q Darwin; then
- squishFile="squish-$version-qt$qtBranch-macx86_64.dmg"
+ squishFile="squish-nosignalhandler-$version-qt$qtBranch-macx86_64.dmg"
fi
squishLicenseUrl="ci-files01-hki.intra.qt.io:/hdd/www/input/squish/coin/"
diff --git a/coin/provisioning/common/windows/squishInstall.ps1 b/coin/provisioning/common/windows/squishInstall.ps1
index 2cc45785..f8d600d7 100644
--- a/coin/provisioning/common/windows/squishInstall.ps1
+++ b/coin/provisioning/common/windows/squishInstall.ps1
@@ -38,10 +38,10 @@
# NOTE! Make sure 64bit versions are always installed before 32bit,
# because they use same folder name before a rename
-$version = "6.4.3"
+$version = "6.5"
# Qt branch without dot (*.*)
-$qtBranch = "512x"
+$qtBranch = "513x"
# So far Squish built with Qt5.12 works also with 5.13, but we have to be prepared that on some point
# the compatibility breaks, and we may need to have separate Squish packages for different Qt versions.
@@ -62,11 +62,7 @@ Function DownloadAndInstallSquish {
[string]$bit,
[string]$squishPackage
)
- # MinGW x86 available only with Qt5.11, to be updated when Squish is supporting 5.13
- if ("$bit" -eq "win32" -and $squishPackage.StartsWith("mingw")) {
- $qtBranch = "511x"
- }
- $SquishUrl = $squishBranchUrl + "\squish-" + $version + "-qt" + $qtBranch + "-" + $bit + "-" + $squishPackage + ".exe"
+ $SquishUrl = $squishBranchUrl + "\squish-nosignalhandler-" + $version + "-qt" + $qtBranch + "-" + $bit + "-" + $squishPackage + ".exe"
$SquishInstaller = "$targetDir\$squishPackage.exe"
$SquishParameters = "unattended=1 targetdir=$targetDir\$squishPackage"
diff --git a/coin/provisioning/qtci-linux-Ubuntu-18.04-x86_64/02-apt.sh b/coin/provisioning/qtci-linux-Ubuntu-18.04-x86_64/02-apt.sh
index 89b1eb7f..d5f9ef7a 100755
--- a/coin/provisioning/qtci-linux-Ubuntu-18.04-x86_64/02-apt.sh
+++ b/coin/provisioning/qtci-linux-Ubuntu-18.04-x86_64/02-apt.sh
@@ -169,6 +169,8 @@ installPackages+=(git-lfs)
installPackages+=(chrpath)
installPackages+=(gawk)
installPackages+=(texinfo)
+# Needed for Poppler test in QtWebEngine
+installPackages+=(libpoppler-cpp-dev)
echo "Running update for apt"
waitLoop