summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHeikki Halmet <heikki.halmet@qt.io>2017-12-01 09:34:56 +0200
committerAntti Kokko <antti.kokko@qt.io>2017-12-01 17:55:19 +0000
commitadcdf7b49f52e745009ff7e37e07c2d831ad82dc (patch)
tree2eb7f3867f57233dd85ffa97cbfa6990381456a7
parent6e54086be53420af0be2b417c36a4ce284f3f979 (diff)
Provisioning: Install Devtoolset-4 to Rhel 7.4v5.10.0-rc3v5.10.0
Gcc need to be downgraded from 6 to 5, because Gcc 6 is too new for the latest Ubuntu LTS (16.04). This means Devtoolset-4 need to be used instead of Devtoolset-6. Task-number: QTBUG-64820 Change-Id: I2601aaaff5f3bbbadd867105fd4155239ab89825 Reviewed-by: Konstantin Tokarev <annulen@yandex.ru>
-rwxr-xr-xcoin/provisioning/qtci-linux-RHEL-7.4-x86_64/003-install-devtoolset.sh (renamed from coin/provisioning/qtci-linux-RHEL-7.4-x86_64/003-install-devtoolset6.sh)4
-rwxr-xr-xcoin/provisioning/qtci-linux-RHEL-7.4-x86_64/010-openssl_for_android_linux.sh2
2 files changed, 3 insertions, 3 deletions
diff --git a/coin/provisioning/qtci-linux-RHEL-7.4-x86_64/003-install-devtoolset6.sh b/coin/provisioning/qtci-linux-RHEL-7.4-x86_64/003-install-devtoolset.sh
index ef65b881..439e2db5 100755
--- a/coin/provisioning/qtci-linux-RHEL-7.4-x86_64/003-install-devtoolset6.sh
+++ b/coin/provisioning/qtci-linux-RHEL-7.4-x86_64/003-install-devtoolset.sh
@@ -34,7 +34,7 @@
#############################################################################
sudo yum-config-manager --enable rhel-server-rhscl7-rpms
-sudo yum -y install devtoolset-6
+sudo yum -y install devtoolset-4
-echo "source /opt/rh/devtoolset-6/enable" >> ~/.bashrc
+echo "source /opt/rh/devtoolset-4/enable" >> ~/.bashrc
diff --git a/coin/provisioning/qtci-linux-RHEL-7.4-x86_64/010-openssl_for_android_linux.sh b/coin/provisioning/qtci-linux-RHEL-7.4-x86_64/010-openssl_for_android_linux.sh
index 05b73729..b69295fc 100755
--- a/coin/provisioning/qtci-linux-RHEL-7.4-x86_64/010-openssl_for_android_linux.sh
+++ b/coin/provisioning/qtci-linux-RHEL-7.4-x86_64/010-openssl_for_android_linux.sh
@@ -33,5 +33,5 @@
##
#############################################################################
-source /opt/rh/devtoolset-6/enable
+source /opt/rh/devtoolset-4/enable
source "${BASH_SOURCE%/*}/../common/openssl_for_android_linux.sh"