summaryrefslogtreecommitdiffstats
path: root/coin
diff options
context:
space:
mode:
Diffstat (limited to 'coin')
-rw-r--r--coin/platform_configs/default.yaml102
-rw-r--r--coin/platform_configs/flashing-wizard.yaml8
-rw-r--r--coin/platform_configs/meta-boot2qt.yaml83
-rw-r--r--coin/platform_configs/qdb.yaml8
-rw-r--r--coin/platform_configs/qt5.yaml88
-rw-r--r--coin/platform_configs/qtbase.yaml47
-rw-r--r--coin/platform_configs/qtconnectivity.yaml6
-rw-r--r--coin/platform_configs/qtdeclarative.yaml9
-rw-r--r--coin/platform_configs/qtsaferenderer.yaml5
-rw-r--r--coin/platform_configs/qtsdk.yaml4
-rw-r--r--coin/platform_configs/qtsvg.yaml30
-rw-r--r--coin/platform_configs/qtwebkit.yaml2
-rw-r--r--coin/platform_configs/tqtc-qt-config-gui.yaml10
-rw-r--r--coin/platform_configs/tqtc-qt-rta.yaml5
-rwxr-xr-xcoin/provisioning/common/linux/cmake_linux.sh11
-rwxr-xr-xcoin/provisioning/common/linux/vcpkg.sh73
-rwxr-xr-xcoin/provisioning/common/macos/cmake.sh12
-rwxr-xr-xcoin/provisioning/common/macos/python3.sh20
-rw-r--r--coin/provisioning/common/shared/vcpkg_version.txt1
-rwxr-xr-xcoin/provisioning/common/unix/install_protobuff.sh2
-rw-r--r--coin/provisioning/common/windows/cmake.ps18
-rw-r--r--coin/provisioning/common/windows/install-vcpkg.ps169
-rwxr-xr-xcoin/provisioning/qtci-linux-RHEL-7.6-x86_64/03-install-devtoolset.sh4
-rwxr-xr-xcoin/provisioning/qtci-linux-RHEL-7.6-x86_64/04-install-packages.sh12
-rwxr-xr-xcoin/provisioning/qtci-linux-RHEL-7.6-x86_64/40-install-cmake.sh (renamed from coin/provisioning/qtci-linux-RHEL-7.6-x86_64/06-cmake.sh)0
-rwxr-xr-xcoin/provisioning/qtci-linux-RHEL-7.6-x86_64/56-vcpkg.sh5
-rwxr-xr-xcoin/provisioning/qtci-linux-SLES-15-x86_64/02-zypperpackages.sh2
-rwxr-xr-xcoin/provisioning/qtci-linux-Ubuntu-18.04-x86_64/02-apt.sh6
-rwxr-xr-xcoin/provisioning/qtci-linux-Ubuntu-18.04-x86_64/40-install-cmake.sh (renamed from coin/provisioning/qtci-linux-Ubuntu-18.04-x86_64/40-cmake.sh)0
-rwxr-xr-xcoin/provisioning/qtci-linux-openSUSE-15.0-x86_64/02-zypperpackages.sh5
-rwxr-xr-xcoin/provisioning/qtci-macos-10.13-x86_64/25-install-cmake.sh (renamed from coin/provisioning/qtci-macos-10.13-x86_64/25-cmake.sh)0
-rwxr-xr-xcoin/provisioning/qtci-macos-10.13-x86_64/26-freetype.sh5
-rwxr-xr-xcoin/provisioning/qtci-macos-10.13-x86_64/26-ninja.sh5
-rwxr-xr-xcoin/provisioning/qtci-macos-10.13-x86_64/26-pcre2.sh5
-rwxr-xr-xcoin/provisioning/qtci-macos-10.14-x86_64/26-freetype.sh5
-rwxr-xr-xcoin/provisioning/qtci-macos-10.14-x86_64/26-ninja.sh5
-rwxr-xr-xcoin/provisioning/qtci-macos-10.14-x86_64/26-pcre2.sh5
-rw-r--r--coin/provisioning/qtci-windows-10-x86_64/90-install-vcpkg.ps12
38 files changed, 402 insertions, 267 deletions
diff --git a/coin/platform_configs/default.yaml b/coin/platform_configs/default.yaml
index 5cbb2f68..a09507d3 100644
--- a/coin/platform_configs/default.yaml
+++ b/coin/platform_configs/default.yaml
@@ -2,129 +2,81 @@ Version: 2
Module only: True
Configurations:
-
- Template: 'qtci-windows-10-x86_64-15'
- Compiler: 'MSVC2015'
- Features: ['DisableTests']
- Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -developer-build -release -angle -qtnamespace TestNamespace -qtlibinfix TestInfix -nomake tests -openssl -I %OPENSSL_INCLUDE_x64% -L %OPENSSL_LIB_x64% -plugin-sql-mysql -plugin-sql-sqlite -plugin-sql-odbc -I %MYSQL_INCLUDE_x64% -L %MYSQL_LIB_x64% -plugin-sql-psql -I %POSTGRESQL_INCLUDE_x64% -L %POSTGRESQL_LIB_x64%'
--
Template: 'qtci-windows-7-x86-3'
Compiler: 'Mingw73'
+ Features: ['UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -developer-build -release -nomake tests -opengl dynamic -nomake examples -openssl -I %OPENSSL_INCLUDE_x86% -L %OPENSSL_LIB_x86% -plugin-sql-mysql -plugin-sql-sqlite -plugin-sql-odbc -I %MYSQL_INCLUDE_x86% -L %MYSQL_LIB_x86% -plugin-sql-psql -I %POSTGRESQL_INCLUDE_x86% -L %POSTGRESQL_LIB_x86% -platform win32-g++'
-
Template: 'qtci-windows-10-x86_64-15'
- Target arch: 'x86'
- Compiler: 'MSVC2017'
- Features: ['Packaging']
- Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -debug-and-release -release -force-debug-info -nomake tests -opengl dynamic -nomake examples -openssl -I %OPENSSL_INCLUDE_x86% -L %OPENSSL_LIB_x86% -no-sql-mysql -plugin-sql-sqlite -plugin-sql-odbc -I %MYSQL_INCLUDE_x86% -L %MYSQL_LIB_x86% -plugin-sql-psql -I %POSTGRESQL_INCLUDE_x86% -L %POSTGRESQL_LIB_x86%'
--
- Template: 'qtci-windows-10-x86_64-15'
- Target arch: 'x86'
- Compiler: 'MSVC2019'
- Features: ['DisableTests']
- Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -debug-and-release -release -force-debug-info -nomake tests -opengl dynamic -nomake examples -openssl -I %OPENSSL_INCLUDE_x86% -L %OPENSSL_LIB_x86% -no-sql-mysql -plugin-sql-sqlite -plugin-sql-odbc -I %MYSQL_INCLUDE_x86% -L %MYSQL_LIB_x86% -plugin-sql-psql -I %POSTGRESQL_INCLUDE_x86% -L %POSTGRESQL_LIB_x86%'
--
- Template: 'qtci-windows-10-x86_64-15'
- Compiler: 'MSVC2015'
- Features: ['Packaging', 'DisableTests']
- Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -debug-and-release -release -force-debug-info -nomake tests -nomake examples -opengl dynamic -openssl -I %OPENSSL_INCLUDE_x64% -L %OPENSSL_LIB_x64% -no-sql-mysql -plugin-sql-sqlite -plugin-sql-odbc -I %MYSQL_INCLUDE_x64% -L %MYSQL_LIB_x64% -plugin-sql-psql -I %POSTGRESQL_INCLUDE_x64% -L %POSTGRESQL_LIB_x64%'
--
- Template: 'qtci-windows-10-x86_64-15'
- Target os: 'WinRT_10'
- Target arch: 'x86'
- Compiler: 'MSVC2015'
- Features: ['DisableTests']
- Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -debug-and-release -release -force-debug-info -nomake tests -nomake examples -no-sql-mysql -platform win32-msvc2015 -xplatform winrt-x86-msvc2015'
--
- Template: 'qtci-windows-10-x86_64-15'
- Target os: 'WinRT_10'
- Target arch: 'armv7'
- Compiler: 'MSVC2015'
- Features: ['Packaging', 'DisableTests']
- Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -debug-and-release -release -force-debug-info -nomake tests -nomake examples -no-sql-mysql -platform win32-msvc2015 -xplatform winrt-arm-msvc2015'
--
- Template: 'qtci-windows-10-x86_64-15'
Compiler: 'MSVC2017'
- Features: ['Packaging']
+ Features: ['Packaging', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -debug-and-release -release -force-debug-info -nomake tests -opengl dynamic -nomake examples -openssl -I %OPENSSL_INCLUDE_x64% -L %OPENSSL_LIB_x64% -no-sql-mysql -plugin-sql-sqlite -plugin-sql-odbc -I %MYSQL_INCLUDE_x64% -L %MYSQL_LIB_x64% -plugin-sql-psql -I %POSTGRESQL_INCLUDE_x64% -L %POSTGRESQL_LIB_x64%'
-
Template: 'qtci-windows-10-x86_64-15'
Compiler: 'MSVC2019'
- Features: ['DisableTests']
+ Features: ['DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -debug-and-release -release -force-debug-info -nomake tests -opengl dynamic -nomake examples -openssl -I %OPENSSL_INCLUDE_x64% -L %OPENSSL_LIB_x64% -no-sql-mysql -plugin-sql-sqlite -plugin-sql-odbc -I %MYSQL_INCLUDE_x64% -L %MYSQL_LIB_x64% -plugin-sql-psql -I %POSTGRESQL_INCLUDE_x64% -L %POSTGRESQL_LIB_x64%'
-
Template: 'qtci-linux-Ubuntu-18.04-x86_64'
Compiler: 'GCC'
- Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -developer-build -nomake tests -R . -qtlibinfix TestInfix -qtnamespace TestNamespace -openssl -I {{.Env.OPENSSL_HOME}}/include -L {{.Env.OPENSSL_HOME}}/lib'
--
- Template: 'qtci-linux-Ubuntu-18.04-x86_64'
- Compiler: 'GCC'
+ Features: ['UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -force-debug-info -nomake tests -no-widgets -R . -openssl -I {{.Env.OPENSSL_HOME}}/include -L {{.Env.OPENSSL_HOME}}/lib'
-
Template: 'qtci-linux-Ubuntu-18.04-x86_64'
Compiler: 'GCC'
- Features: ['OutOfSourceBuild', 'Documentation']
- Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -developer-build -nomake tests -R . -qtlibinfix TestInfix -qtnamespace TestNamespace -openssl -I {{.Env.OPENSSL_HOME}}/include -L {{.Env.OPENSSL_HOME}}/lib'
-
--
- Template: 'qtci-linux-openSUSE-15.0-x86_64'
- Compiler: 'GCC'
- Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -developer-build -nomake tests -nomake examples -no-pch -R . -openssl -I {{.Env.OPENSSL_HOME}}/include -L {{.Env.OPENSSL_HOME}}/lib'
--
- Template: 'qtci-linux-openSUSE-15.0-x86_64'
- Compiler: 'ICC_18'
- Features: ['DisableTests']
- Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -developer-build -nomake tests -nomake examples -no-pch -system-sqlite -R . -platform linux-icc-64 -openssl -I {{.Env.OPENSSL_HOME}}/include -L {{.Env.OPENSSL_HOME}}/lib'
+ Features: ['OutOfSourceBuild', 'Documentation', 'UseLegacyInstructions']
+ Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -developer-build -no-warnings-are-errors -nomake tests -R . -qtlibinfix TestInfix -qtnamespace TestNamespace -openssl -I {{.Env.OPENSSL_HOME}}/include -L {{.Env.OPENSSL_HOME}}/lib'
-
Template: 'qtci-linux-openSUSE-15.0-x86_64'
Target os: 'WebAssembly'
Compiler: 'GCC'
- Features: ['Packaging', 'DisableTests']
+ Features: ['Packaging', 'DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -developer-build -release -static -nomake tests -nomake examples -no-sql-mysql -no-pch -no-dbus -no-headersclean -no-ssl -no-warnings-are-errors -no-feature-thread -xplatform wasm-emscripten'
-
Template: 'qtci-linux-SLES-15-x86_64'
Compiler: 'GCC'
- Features: ['DisableTests']
+ Features: ['DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -developer-build -no-sql-mysql -no-pch -R . -openssl -I {{.Env.OPENSSL_HOME}}/include -L {{.Env.OPENSSL_HOME}}/lib'
-
Template: 'qtci-linux-RHEL-7.6-x86_64'
Compiler: 'GCC'
- Features: ['Packaging']
+ Features: ['Packaging', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -release -nomake tests -nomake examples -no-libudev -no-use-gold-linker -force-debug-info -separate-debug-info -no-sql-mysql -plugin-sql-psql -plugin-sql-sqlite -qt-libjpeg -qt-libpng -xcb -bundled-xcb-xinput -sysconfdir /etc/xdg -qt-pcre -qt-harfbuzz -R . -openssl -I {{.Env.OPENSSL_HOME}}/include -L {{.Env.OPENSSL_HOME}}/lib QMAKE_LFLAGS_APP+=-s'
-
- Template: 'qtci-macos-10.13-x86_64-2'
+ Template: 'qtci-macos-10.14-x86_64'
Compiler: 'Clang'
- Features: ['Packaging']
+ Features: ['DisableTests', 'Packaging', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /Users/qt/work/install -release -force-debug-info -separate-debug-info -nomake tests -nomake examples -no-sql-mysql -plugin-sql-psql -plugin-sql-sqlite -sysconfdir /Library/Preferences/Qt -I/usr/local/opt/openssl/include'
-
Template: 'qtci-macos-10.14-x86_64'
Compiler: 'Clang'
- Features: ['DisableTests']
+ Features: ['DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /Users/qt/work/install -debug-and-release -release -nomake tests -no-sql-mysql -plugin-sql-psql -plugin-sql-sqlite -sysconfdir /Library/Preferences/Qt -I/usr/local/opt/openssl/include'
-
Template: 'qtci-macos-10.14-x86_64'
Compiler: 'Clang'
- Features: ['DisableTests']
+ Features: ['DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /Users/qt/work/install -developer-build -release -no-pch -no-framework -qtnamespace TestNamespace -nomake tests -nomake examples -I/usr/local/opt/openssl/include'
-
Template: 'qtci-macos-10.14-x86_64'
Target os: 'IOS_ANY'
Target arch: 'multi'
Compiler: 'Clang'
- Features: ['Packaging', 'DisableTests']
+ Features: ['Packaging', 'DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /Users/qt/work/install -debug-and-release -nomake tests -no-icu -nomake examples -no-sql-mysql -no-sql-psql -plugin-sql-sqlite -static -xplatform macx-ios-clang'
-
Template: 'qtci-macos-10.14-x86_64'
Target os: 'TvOS_ANY'
Target arch: 'multi'
Compiler: 'Clang'
- Features: ['DisableTests']
+ Features: ['DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /Users/qt/work/install -debug-and-release -nomake tests -nomake examples -no-sql-mysql -no-sql-psql -plugin-sql-sqlite -xplatform macx-tvos-clang'
-
Template: 'qtci-macos-10.14-x86_64'
Target os: 'WatchOS_ANY'
Target arch: 'multi'
Compiler: 'Clang'
- Features: ['DisableTests']
+ Features: ['DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /Users/qt/work/install -debug-and-release -nomake tests -nomake examples -no-sql-mysql -no-sql-psql -plugin-sql-sqlite -xplatform macx-watchos-clang'
-
Template: 'qtci-linux-RHEL-7.6-x86_64'
@@ -132,13 +84,14 @@ Configurations:
Target arch: 'multi'
Compiler: 'Clang'
Target compiler: 'Clang'
- Features: ['Packaging', 'DisableTests']
+ Features: ['Packaging', 'DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -release -nomake tests -nomake examples -no-sql-mysql -no-dbus -no-use-gold-linker -no-qpa-platform-guard -opengl es2 -sysconfdir /etc/xdg -openssl -I {{.Env.OPENSSL_ANDROID_HOME}}/include -xplatform android-clang -android-sdk /opt/android/sdk -android-ndk /opt/android/android-ndk-r20 -android-ndk-host linux-x86_64'
-
Template: 'qtci-linux-Ubuntu-18.04-x86_64'
Target os: 'QEMU'
Target arch: 'armv7'
Compiler: 'GCC'
+ Features: ['UseLegacyInstructions']
Environment variables: ['GST_PLUGIN_SCANNER=/opt/yocto-armv7/sysroots/armv7at2hf-neon-poky-linux-gnueabi/usr/libexec/gstreamer-1.0/gst-plugin-scanner']
Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -release -nomake tests -nomake examples -no-xcb -R . -openssl -device linux-imx7-g++ -device-option CROSS_COMPILE=/opt/yocto-armv7/sysroots/x86_64-pokysdk-linux/usr/bin/arm-poky-linux-gnueabi/arm-poky-linux-gnueabi- -device-option DISTRO_OPTS="hard-float boot2qt" -sysroot /opt/yocto-armv7/sysroots/armv7at2hf-neon-poky-linux-gnueabi -extprefix /home/qt/work/install -mysql_config /opt/yocto-armv7/sysroots/armv7at2hf-neon-poky-linux-gnueabi/usr/bin/mysql_config -psql_config /dev/null -tslib'
-
@@ -146,6 +99,7 @@ Configurations:
Target os: 'QEMU'
Target arch: 'arm64'
Compiler: 'GCC'
+ Features: ['UseLegacyInstructions']
Environment variables: ['GST_PLUGIN_SCANNER=/opt/yocto-arm64/sysroots/aarch64-poky-linux/usr/libexec/gstreamer-1.0/gst-plugin-scanner']
Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -release -nomake tests -nomake examples -no-xcb -R . -openssl -device linux-generic-g++ -device-option CROSS_COMPILE=/opt/yocto-arm64/sysroots/x86_64-pokysdk-linux/usr/bin/aarch64-poky-linux/aarch64-poky-linux- -device-option DISTRO_OPTS=boot2qt -sysroot /opt/yocto-arm64/sysroots/aarch64-poky-linux -extprefix /home/qt/work/install -mysql_config /opt/yocto-arm64/sysroots/aarch64-poky-linux/usr/bin/mysql_config -psql_config /dev/null -tslib'
-
@@ -153,23 +107,9 @@ Configurations:
Target os: 'QEMU'
Target arch: 'mips64'
Compiler: 'GCC'
- Features: ['DisableTests']
+ Features: ['DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -release -nomake tests -nomake examples -no-xcb -R . -openssl -device linux-generic-g++ -device-option CROSS_COMPILE=/opt/yocto-mips64/sysroots/x86_64-pokysdk-linux/usr/bin/mips64-poky-linux/mips64-poky-linux- -device-option DISTRO_OPTS=boot2qt -sysroot /opt/yocto-mips64/sysroots/mips64-poky-linux -extprefix /home/qt/work/install -mysql_config /opt/yocto-mips64/sysroots/mips64-poky-linux/usr/bin/mysql_config -psql_config /dev/null -tslib'
-
Template: 'qtci-linux-Ubuntu-18.04-x86_64'
Compiler: 'GCC'
- Features: ['TestOnly', 'LicenseCheck']
--
- Template: 'qtci-linux-RHEL-7.6-x86_64'
- Target os: 'INTEGRITY_11_04'
- Target arch: 'armv7'
- Compiler: 'GCC'
- Features: ['DisableTests']
- Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -release -nomake tests -nomake examples -no-use-gold-linker -opengl es2 -xplatform integrity-armv7-imx6'
--
- Template: 'qtci-linux-RHEL-7.6-x86_64'
- Target os: 'QNX_700'
- Target arch: 'armv7'
- Compiler: 'GCC'
- Features: ['Packaging', 'DisableTests']
- Configure arguments: '-opensource -confirm-license -verbose -extprefix /home/qt/work/install -release -nomake tests -nomake examples -no-use-gold-linker -opengl es2 -no-sql-mysql -qpa qnx -xplatform qnx-armle-v7-qcc'
+ Features: ['TestOnly', 'LicenseCheck', 'UseLegacyInstructions']
diff --git a/coin/platform_configs/flashing-wizard.yaml b/coin/platform_configs/flashing-wizard.yaml
index f0f0e51d..c281bb86 100644
--- a/coin/platform_configs/flashing-wizard.yaml
+++ b/coin/platform_configs/flashing-wizard.yaml
@@ -4,20 +4,20 @@ Configurations:
-
Template: 'qtci-windows-10-x86_64-14'
Compiler: 'MSVC2017'
- Features: ['Packaging']
+ Features: ['Packaging', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -debug-and-release -release -force-debug-info -nomake tests -opengl dynamic -nomake examples -openssl -I %OPENSSL_INCLUDE_x64% -L %OPENSSL_LIB_x64% -no-sql-mysql -plugin-sql-sqlite -plugin-sql-odbc -I %MYSQL_INCLUDE_x64% -L %MYSQL_LIB_x64% -plugin-sql-psql -I %POSTGRESQL_INCLUDE_x64% -L %POSTGRESQL_LIB_x64% -static -no-icu'
-
Template: 'qtci-windows-10-x86_64-14'
Compiler: 'MSVC2017'
Target arch: 'x86'
- Features: ['Packaging']
+ Features: ['Packaging', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -debug-and-release -release -force-debug-info -nomake tests -nomake examples -opengl dynamic -openssl -I %OPENSSL_INCLUDE_x86% -L %OPENSSL_LIB_x86% -no-sql-mysql -plugin-sql-sqlite -plugin-sql-odbc -I %MYSQL_INCLUDE_x86% -L %MYSQL_LIB_x86% -plugin-sql-psql -I %POSTGRESQL_INCLUDE_x86% -L %POSTGRESQL_LIB_x86% -static -no-icu'
-
Template: 'qtci-linux-RHEL-7.6-x86_64'
Compiler: 'GCC'
- Features: ['Packaging']
+ Features: ['Packaging', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -release -nomake tests -nomake examples -no-libudev -no-use-gold-linker -force-debug-info -no-sql-mysql -plugin-sql-psql -plugin-sql-sqlite -qt-libjpeg -qt-libpng -qt-xcb -sysconfdir /etc/xdg -qt-pcre -qt-harfbuzz -openssl -I {{.Env.OPENSSL_HOME}}/include -L {{.Env.OPENSSL_HOME}}/lib QMAKE_LFLAGS_APP+=-s -static -no-icu'
-
Template: 'qtci-linux-Ubuntu-18.04-x86_64'
Compiler: 'GCC'
- Features: ['TestOnly', 'LicenseCheck']
+ Features: ['TestOnly', 'LicenseCheck', 'UseLegacyInstructions']
diff --git a/coin/platform_configs/meta-boot2qt.yaml b/coin/platform_configs/meta-boot2qt.yaml
index 95cc79c4..e1446696 100644
--- a/coin/platform_configs/meta-boot2qt.yaml
+++ b/coin/platform_configs/meta-boot2qt.yaml
@@ -1,40 +1,43 @@
--
- Template: 'qtci-linux-Ubuntu-18.04-x86_64'
- Compiler: 'Yocto'
- Target arch: 'TARGET1'
--
- Template: 'qtci-linux-Ubuntu-18.04-x86_64'
- Compiler: 'Yocto'
- Target arch: 'TARGET2'
--
- Template: 'qtci-linux-Ubuntu-18.04-x86_64'
- Compiler: 'Yocto'
- Target arch: 'TARGET3'
--
- Template: 'qtci-linux-Ubuntu-18.04-x86_64'
- Compiler: 'Yocto'
- Target arch: 'TARGET4'
--
- Template: 'qtci-linux-Ubuntu-18.04-x86_64'
- Compiler: 'Yocto'
- Target arch: 'TARGET5'
--
- Template: 'qtci-linux-Ubuntu-18.04-x86_64'
- Compiler: 'Yocto'
- Target arch: 'TARGET6'
--
- Template: 'qtci-linux-Ubuntu-18.04-x86_64'
- Compiler: 'Yocto'
- Target arch: 'TARGET7'
--
- Template: 'qtci-linux-Ubuntu-18.04-x86_64'
- Compiler: 'Yocto'
- Target arch: 'TARGET8'
--
- Template: 'qtci-linux-Ubuntu-18.04-x86_64'
- Compiler: 'Yocto'
- Target arch: 'TARGET9'
--
- Template: 'qtci-linux-Ubuntu-18.04-x86_64'
- Compiler: 'Yocto'
- Target arch: 'TARGET10'
+Version: 2
+Module only: True
+Configurations:
+ -
+ Template: 'qtci-linux-Ubuntu-18.04-x86_64'
+ Compiler: 'Yocto'
+ Target arch: 'TARGET1'
+ -
+ Template: 'qtci-linux-Ubuntu-18.04-x86_64'
+ Compiler: 'Yocto'
+ Target arch: 'TARGET2'
+ -
+ Template: 'qtci-linux-Ubuntu-18.04-x86_64'
+ Compiler: 'Yocto'
+ Target arch: 'TARGET3'
+ -
+ Template: 'qtci-linux-Ubuntu-18.04-x86_64'
+ Compiler: 'Yocto'
+ Target arch: 'TARGET4'
+ -
+ Template: 'qtci-linux-Ubuntu-18.04-x86_64'
+ Compiler: 'Yocto'
+ Target arch: 'TARGET5'
+ -
+ Template: 'qtci-linux-Ubuntu-18.04-x86_64'
+ Compiler: 'Yocto'
+ Target arch: 'TARGET6'
+ -
+ Template: 'qtci-linux-Ubuntu-18.04-x86_64'
+ Compiler: 'Yocto'
+ Target arch: 'TARGET7'
+ -
+ Template: 'qtci-linux-Ubuntu-18.04-x86_64'
+ Compiler: 'Yocto'
+ Target arch: 'TARGET8'
+ -
+ Template: 'qtci-linux-Ubuntu-18.04-x86_64'
+ Compiler: 'Yocto'
+ Target arch: 'TARGET9'
+ -
+ Template: 'qtci-linux-Ubuntu-18.04-x86_64'
+ Compiler: 'Yocto'
+ Target arch: 'TARGET10'
diff --git a/coin/platform_configs/qdb.yaml b/coin/platform_configs/qdb.yaml
index 02198976..d36a21d2 100644
--- a/coin/platform_configs/qdb.yaml
+++ b/coin/platform_configs/qdb.yaml
@@ -5,19 +5,19 @@ Configurations:
Template: 'qtci-windows-10-x86_64-14'
Compiler: 'MSVC2015'
Target arch: 'x86'
- Features: ['Packaging']
+ Features: ['Packaging', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -nomake tests -verbose -prefix c:\Users\qt\work\install -debug-and-release -release -force-debug-info -opengl dynamic -static -no-icu -nomake examples -openssl -I %OPENSSL_INCLUDE_x86% -L %OPENSSL_LIB_x86% -plugin-sql-mysql -plugin-sql-sqlite -plugin-sql-odbc -I %MYSQL_INCLUDE_x86% -L %MYSQL_LIB_x86%'
-
Template: 'qtci-windows-10-x86_64-14'
Compiler: 'MSVC2015'
- Features: ['Packaging']
+ Features: ['Packaging', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -nomake tests -verbose -prefix c:\Users\qt\work\install -debug-and-release -release -force-debug-info -opengl dynamic -static -no-icu -nomake examples -openssl -I %OPENSSL_INCLUDE_x64% -L %OPENSSL_LIB_x64% -plugin-sql-mysql -plugin-sql-sqlite -plugin-sql-odbc -I %MYSQL_INCLUDE_x64% -L %MYSQL_LIB_x64%'
-
Template: 'qtci-linux-RHEL-7.6-x86_64'
Compiler: 'GCC'
- Features: ['Packaging']
+ Features: ['Packaging', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -release -nomake tests -nomake examples -no-libudev -no-use-gold-linker -force-debug-info -no-sql-mysql -plugin-sql-psql -plugin-sql-sqlite -qt-libjpeg -qt-libpng -qt-xcb -sysconfdir /etc/xdg -qt-pcre -qt-harfbuzz -openssl -I {{.Env.OPENSSL_HOME}}/include -L {{.Env.OPENSSL_HOME}}/lib QMAKE_LFLAGS_APP+=-s -static -no-icu'
-
Template: 'qtci-linux-Ubuntu-18.04-x86_64'
Compiler: 'GCC'
- Features: ['TestOnly', 'LicenseCheck']
+ Features: ['TestOnly', 'LicenseCheck', 'UseLegacyInstructions']
diff --git a/coin/platform_configs/qt5.yaml b/coin/platform_configs/qt5.yaml
index e1d20a71..c98a351a 100644
--- a/coin/platform_configs/qt5.yaml
+++ b/coin/platform_configs/qt5.yaml
@@ -1,106 +1,32 @@
-
- Template: 'qtci-windows-10-x86_64-15'
- Target os: 'WinRT_10'
- Compiler: 'MSVC2015'
- Features: ['Packaging', 'DisableTests']
- Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -release -debug-and-release -nomake tests -nomake examples -force-debug-info -no-sql-mysql -platform win32-msvc2015 -xplatform winrt-x64-msvc2015'
--
- Template: 'qtci-windows-10-x86_64-15'
- Target os: 'WinRT_10'
- Target arch: 'x86'
- Compiler: 'MSVC2017'
- Features: ['Packaging', 'DisableTests']
- Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -release -debug-and-release -nomake tests -nomake examples -force-debug-info -no-sql-mysql -platform win32-msvc2017 -xplatform winrt-x86-msvc2017'
--
Template: 'qtci-windows-7-x86-3'
Compiler: 'Mingw73'
- Features: ['Packaging', 'DisableTests']
+ Features: ['Packaging', 'DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -release -force-debug-info -separate-debug-info -nomake tests -nomake examples -opengl dynamic -openssl -I %OPENSSL_INCLUDE_x86% -L %OPENSSL_LIB_x86% -no-sql-mysql -plugin-sql-sqlite -plugin-sql-odbc -I %MYSQL_INCLUDE_x86% -L %MYSQL_LIB_x86% -plugin-sql-psql -I %POSTGRESQL_INCLUDE_x86% -L %POSTGRESQL_LIB_x86% -platform win32-g++'
-
Template: 'qtci-windows-10-x86_64-15'
Compiler: 'Mingw73'
- Features: ['Packaging', 'DisableTests']
+ Features: ['Packaging', 'DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -release -force-debug-info -separate-debug-info -nomake tests -nomake examples -opengl dynamic -openssl -I %OPENSSL_INCLUDE_x64% -L %OPENSSL_LIB_x64% -no-sql-mysql -plugin-sql-sqlite -plugin-sql-odbc -I %MYSQL_INCLUDE_x64% -L %MYSQL_LIB_x64% -plugin-sql-psql -I %POSTGRESQL_INCLUDE_x64% -L %POSTGRESQL_LIB_x64% -platform win32-g++'
-
Template: 'qtci-windows-10-x86_64-15'
- Target os: 'WinRT_10'
- Target arch: 'armv7'
- Compiler: 'MSVC2017'
- Features: ['Packaging', 'DisableTests']
- Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -release -debug-and-release -nomake tests -nomake examples -force-debug-info -no-sql-mysql -platform win32-msvc2017 -xplatform winrt-arm-msvc2017'
--
- Template: 'qtci-windows-10-x86_64-15'
- Target os: 'WinRT_10'
- Compiler: 'MSVC2017'
- Features: ['Packaging', 'DisableTests']
- Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -release -debug-and-release -nomake tests -nomake examples -force-debug-info -no-sql-mysql -platform win32-msvc2017 -xplatform winrt-x64-msvc2017'
--
- Template: 'qtci-windows-10-x86_64-15'
Target os: 'Android_ANY'
Target arch: 'multi'
Compiler: 'Mingw73'
Target compiler: 'Clang'
- Features: ['Packaging', 'DisableTests']
+ Features: ['Packaging', 'DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -release -nomake tests -nomake examples -no-sql-mysql -no-dbus -opengl es2 -sysconfdir /etc/xdg -openssl -I c:\utils\openssl-android-master\include -xplatform android-clang -android-sdk C:\Utils\Android -android-ndk c:\Utils\Android\android-ndk-r20'
-
- Template: 'qtci-macos-10.13-x86_64-2'
+ Template: 'qtci-macos-10.14-x86_64'
Target os: 'Android_ANY'
Target arch: 'multi'
Compiler: 'Clang'
Target compiler: 'Clang'
- Features: ['Packaging', 'DisableTests']
+ Features: ['Packaging', 'DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /Users/qt/work/install -release -nomake tests -nomake examples -no-sql-mysql -no-dbus -no-qpa-platform-guard -opengl es2 -sysconfdir /etc/xdg -openssl -I /usr/local/opt/openssl/include -xplatform android-clang -android-sdk /opt/android/sdk -android-ndk /opt/android/android-ndk-r20 -android-ndk-host darwin-x86_64'
-
- Template: 'qtci-macos-10.13-x86_64-2'
- Target os: 'QNX_700'
- Target arch: 'x86'
- Compiler: 'GCC'
- Features: ['DisableTests']
- Configure arguments: '-opensource -confirm-license -verbose -extprefix /Users/qt/work/install -release -nomake tests -nomake examples -no-use-gold-linker -opengl es2 -qpa qnx -xplatform qnx-x86-qcc'
--
- Template: 'qtci-windows-10-x86_64-15'
- Target os: 'QNX_700'
- Target arch: 'armv7'
- Compiler: 'Mingw73'
- Features: ['Packaging', 'DisableTests']
- Configure arguments: '-opensource -confirm-license -verbose -extprefix c:\Users\qt\work\install -release -nomake tests -nomake examples -no-sql-mysql -opengl es2 -xplatform qnx-armle-v7-qcc'
--
- Template: 'qtci-windows-10-x86_64-15'
- Target os: 'QNX_700'
- Target arch: 'armv8'
- Compiler: 'Mingw73'
- Features: ['Packaging', 'DisableTests']
- Configure arguments: '-opensource -confirm-license -verbose -extprefix c:\Users\qt\work\install -release -opengl es2 -nomake tests -nomake examples -no-sql-mysql -xplatform qnx-aarch64le-qcc'
--
- Template: 'qtci-windows-10-x86_64-15'
- Target os: 'QNX_700'
- Target arch: 'x86_64'
- Compiler: 'Mingw73'
- Features: ['Packaging', 'DisableTests']
- Configure arguments: '-opensource -confirm-license -verbose -extprefix c:\Users\qt\work\install -release -nomake tests -nomake examples -no-sql-mysql -opengl es2 -xplatform qnx-x86-64-qcc'
--
- Template: 'qtci-linux-RHEL-7.6-x86_64'
- Target os: 'QNX_700'
- Target arch: 'armv8'
- Compiler: 'GCC'
- Features: ['Packaging', 'DisableTests']
- Configure arguments: '-opensource -confirm-license -verbose -extprefix /home/qt/work/install -release -nomake tests -nomake examples -no-sql-mysql -no-use-gold-linker -opengl es2 -qpa qnx -xplatform qnx-aarch64le-qcc'
--
- Template: 'qtci-linux-RHEL-7.6-x86_64'
- Target os: 'QNX_700'
- Target arch: 'x86_64'
- Compiler: 'GCC'
- Features: ['Packaging', 'DisableTests']
- Configure arguments: '-opensource -confirm-license -verbose -extprefix /home/qt/work/install -release -nomake tests -nomake examples -no-sql-mysql -no-use-gold-linker -opengl es2 -qpa qnx -xplatform qnx-x86-64-qcc'
--
- Template: 'qtci-windows-10-x86_64-15'
- Target os: 'WebAssembly'
- Compiler: 'Mingw73'
- Features: ['Packaging', 'DisableTests']
- Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -release -nomake examples -nomake tests -no-feature-thread -static -no-dbus -no-headersclean -no-ssl -no-warnings-are-errors -no-pch -platform win32-g++ -xplatform wasm-emscripten'
--
- Template: 'qtci-macos-10.13-x86_64-2'
+ Template: 'qtci-macos-10.14-x86_64'
Target os: 'WebAssembly'
Compiler: 'Clang'
- Features: ['Packaging', 'DisableTests']
+ Features: ['Packaging', 'DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /Users/qt/work/install -release -nomake examples -nomake tests -no-feature-thread -static -no-dbus -no-headersclean -no-ssl -no-warnings-are-errors -no-pch -xplatform wasm-emscripten'
diff --git a/coin/platform_configs/qtbase.yaml b/coin/platform_configs/qtbase.yaml
index 22e16db9..f78aa52e 100644
--- a/coin/platform_configs/qtbase.yaml
+++ b/coin/platform_configs/qtbase.yaml
@@ -1,26 +1,55 @@
+Version: 2
+Configurations:
-
Template: 'qtci-linux-Ubuntu-18.04-x86_64'
Target os: 'QEMU'
Target arch: 'armv7'
Compiler: 'GCC'
- Features: ['DisableTests']
+ Features: ['DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -developer-build -nomake tests -nomake examples -no-xcb -R . -openssl -device linux-imx7-g++ -device-option CROSS_COMPILE=/opt/yocto-armv7/sysroots/x86_64-pokysdk-linux/usr/bin/arm-poky-linux-gnueabi/arm-poky-linux-gnueabi- -device-option DISTRO_OPTS="hard-float boot2qt" -sysroot /opt/yocto-armv7/sysroots/armv7at2hf-neon-poky-linux-gnueabi -extprefix /home/qt/work/install -mysql_config /opt/yocto-armv7/sysroots/armv7at2hf-neon-poky-linux-gnueabi/usr/bin/mysql_config -psql_config /dev/null -tslib'
-
Template: 'qtci-linux-Ubuntu-18.04-x86_64'
Target os: 'QEMU'
Target arch: 'arm64'
Compiler: 'GCC'
- Features: ['DisableTests']
+ Features: ['DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -developer-build -nomake tests -nomake examples -no-xcb -R . -openssl -device linux-generic-g++ -device-option CROSS_COMPILE=/opt/yocto-arm64/sysroots/x86_64-pokysdk-linux/usr/bin/aarch64-poky-linux/aarch64-poky-linux- -device-option DISTRO_OPTS=boot2qt -sysroot /opt/yocto-arm64/sysroots/aarch64-poky-linux -extprefix /home/qt/work/install -mysql_config /opt/yocto-arm64/sysroots/aarch64-poky-linux/usr/bin/mysql_config -psql_config /dev/null -tslib'
-
- Template: 'qtci-windows-10-x86_64-15'
- Target os: 'WinRT_10'
- Target arch: 'x86_64'
- Compiler: 'MSVC2015'
- Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -release -developer-build -static -nomake tests -nomake examples -no-icu -force-debug-info -platform win32-msvc2015 -xplatform winrt-x64-msvc2015'
--
Template: 'qtci-linux-openSUSE-15.0-x86_64'
Target os: 'WebAssembly'
Compiler: 'GCC'
- Features: ['DisableTests']
+ Features: ['DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -release -developer-build -static -nomake tests -nomake examples -no-pch -no-feature-thread -no-dbus -no-headersclean -no-ssl -no-warnings-are-errors -xplatform wasm-emscripten'
+-
+ Template: 'qtci-macos-10.14-x86_64'
+ Compiler: 'Clang'
+ Features: ['UseLegacyInstructions']
+ Configure arguments: '-opensource -confirm-license -verbose -prefix /Users/qt/work/install -developer-build -release -no-pch -no-framework -qtnamespace TestNamespace -nomake tests -nomake examples -I/usr/local/opt/openssl/include'
+-
+ Template: 'qtci-linux-Ubuntu-18.04-x86_64'
+ Compiler: 'GCC'
+ Configure arguments: '-DBUILD_EXAMPLES=ON -DFEATURE_developer_build=ON'
+-
+ Template: 'qtci-linux-openSUSE-15.0-x86_64'
+ Compiler: 'GCC'
+ Configure arguments: '-DBUILD_EXAMPLES=OFF -DBUILD_SHARED_LIBS=OFF'
+-
+ Template: 'qtci-macos-10.14-x86_64'
+ Compiler: 'Clang'
+ Configure arguments: '-DBUILD_EXAMPLES=OFF -DCMAKE_OSX_SYSROOT:PATH=/Applications/Xcode11.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk -DCMAKE_OSX_DEPLOYMENT_TARGET=10.14'
+-
+ Template: 'qtci-windows-10-x86_64-15'
+ Compiler: 'MSVC2019'
+ Configure arguments: '-DCMAKE_BUILD_TYPE=RelWithDebInfo -DBUILD_EXAMPLES=OFF -DCMAKE_TOOLCHAIN_FILE={{.Env.VCPKG_ROOT}}/scripts/buildsystems/vcpkg.cmake'
+-
+ Template: 'qtci-linux-RHEL-7.6-x86_64'
+ Compiler: 'GCC'
+ Configure arguments: '-DBUILD_EXAMPLES=OFF'
+-
+ Template: 'qtci-linux-RHEL-7.6-x86_64'
+ Target os: 'Android_ANY'
+ Target arch: 'arm64'
+ Compiler: 'GCC'
+ Target compiler: 'Clang'
+ Configure arguments: '-DBUILD_EXAMPLES=OFF'
+ Environment variables: ['TARGET_CONFIGURE_ARGS=-DBUILD_EXAMPLES=OFF -DCMAKE_TOOLCHAIN_FILE={{.Env.ANDROID_NDK_ROOT}}/build/cmake/android.toolchain.cmake -DANDROID_SDK_ROOT={{.Env.ANDROID_SDK_HOME}} -DANDROID_ABI=arm64-v8a -DVCPKG_TARGET_TRIPLET=arm64-android -DCMAKE_C_COMPILER_FRONTEND_VARIANT=GNU -DCMAKE_CXX_COMPILER_FRONTEND_VARIANT=GNU']
diff --git a/coin/platform_configs/qtconnectivity.yaml b/coin/platform_configs/qtconnectivity.yaml
deleted file mode 100644
index 13daa23d..00000000
--- a/coin/platform_configs/qtconnectivity.yaml
+++ /dev/null
@@ -1,6 +0,0 @@
--
- Template: 'qtci-windows-10-x86_64-15'
- Target os: 'WinRT_10'
- Target arch: 'x86_64'
- Compiler: 'MSVC2015'
- Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -release -developer-build -static -nomake tests -nomake examples -no-icu -force-debug-info -platform win32-msvc2015 -xplatform winrt-x64-msvc2015'
diff --git a/coin/platform_configs/qtdeclarative.yaml b/coin/platform_configs/qtdeclarative.yaml
index 161875d8..4675343e 100644
--- a/coin/platform_configs/qtdeclarative.yaml
+++ b/coin/platform_configs/qtdeclarative.yaml
@@ -4,21 +4,30 @@
Target arch: 'armv7'
Compiler: 'GCC'
Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -developer-build -nomake tests -nomake examples -no-xcb -R . -openssl -device linux-imx7-g++ -device-option CROSS_COMPILE=/opt/yocto-armv7/sysroots/x86_64-pokysdk-linux/usr/bin/arm-poky-linux-gnueabi/arm-poky-linux-gnueabi- -device-option DISTRO_OPTS="hard-float boot2qt" -sysroot /opt/yocto-armv7/sysroots/armv7at2hf-neon-poky-linux-gnueabi -extprefix /home/qt/work/install -mysql_config /opt/yocto-armv7/sysroots/armv7at2hf-neon-poky-linux-gnueabi/usr/bin/mysql_config -psql_config /dev/null -tslib'
+ Features: ['UseLegacyInstructions']
-
Template: 'qtci-linux-Ubuntu-18.04-x86_64'
Target os: 'QEMU'
Target arch: 'arm64'
Compiler: 'GCC'
Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -developer-build -nomake tests -nomake examples -no-xcb -R . -openssl -device linux-generic-g++ -device-option CROSS_COMPILE=/opt/yocto-arm64/sysroots/x86_64-pokysdk-linux/usr/bin/aarch64-poky-linux/aarch64-poky-linux- -device-option DISTRO_OPTS=boot2qt -sysroot /opt/yocto-arm64/sysroots/aarch64-poky-linux -extprefix /home/qt/work/install -mysql_config /opt/yocto-arm64/sysroots/aarch64-poky-linux/usr/bin/mysql_config -psql_config /dev/null -tslib'
+ Features: ['UseLegacyInstructions']
-
Template: 'qtci-linux-Ubuntu-18.04-x86_64'
Target os: 'QEMU'
Target arch: 'armv7'
Compiler: 'GCC'
Configure arguments: '-opensource -confirm-license -R . -developer-build -device linux-imx7-g++ -device-option CROSS_COMPILE=/opt/yocto-armv7/sysroots/x86_64-pokysdk-linux/usr/bin/arm-poky-linux-gnueabi/arm-poky-linux-gnueabi- -device-option DISTRO_OPTS="hard-float boot2qt" -extprefix /home/qt/work/install -mysql_config /opt/yocto-armv7/sysroots/armv7at2hf-neon-poky-linux-gnueabi/usr/bin/mysql_config -no-xcb -nomake examples -nomake tests -openssl -prefix /home/qt/work/install -psql_config /dev/null -sysroot /opt/yocto-armv7/sysroots/armv7at2hf-neon-poky-linux-gnueabi -tslib -verbose'
+ Features: ['UseLegacyInstructions']
-
Template: 'qtci-linux-Ubuntu-18.04-x86_64'
Target os: 'QEMU'
Target arch: 'arm64'
Compiler: 'GCC'
Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -developer-build -nomake examples -nomake tests -R . -openssl -device linux-generic-g++ -device-option CROSS_COMPILE=/opt/yocto-arm64/sysroots/x86_64-pokysdk-linux/usr/bin/aarch64-poky-linux/aarch64-poky-linux- -device-option DISTRO_OPTS=boot2qt -sysroot /opt/yocto-arm64/sysroots/aarch64-poky-linux -extprefix /home/qt/work/install -mysql_config /opt/yocto-arm64/sysroots/aarch64-poky-linux/usr/bin/mysql_config -psql_config /dev/null -tslib -no-xcb'
+ Features: ['UseLegacyInstructions']
+-
+ Template: 'qtci-macos-10.14-x86_64'
+ Compiler: 'Clang'
+ Features: ['UseLegacyInstructions']
+ Configure arguments: '-opensource -confirm-license -verbose -prefix /Users/qt/work/install -developer-build -release -no-pch -no-framework -qtnamespace TestNamespace -nomake tests -nomake examples -I/usr/local/opt/openssl/include'
diff --git a/coin/platform_configs/qtsaferenderer.yaml b/coin/platform_configs/qtsaferenderer.yaml
index be14923b..63b2d0d3 100644
--- a/coin/platform_configs/qtsaferenderer.yaml
+++ b/coin/platform_configs/qtsaferenderer.yaml
@@ -2,13 +2,14 @@
Template: 'qtci-windows-10-x86_64-15'
Compiler: 'Mingw73'
Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -release -developer-build -nomake tests -opengl dynamic -openssl -I %OPENSSL_INCLUDE_x64% -L %OPENSSL_LIB_x64% -plugin-sql-mysql -plugin-sql-sqlite -plugin-sql-odbc -I %MYSQL_INCLUDE_x64% -L %MYSQL_LIB_x64% -plugin-sql-psql -I %POSTGRESQL_INCLUDE_x64% -L %POSTGRESQL_LIB_x64% -platform win32-g++'
+ Features: ['UseLegacyInstructions']
-
Template: 'qtci-windows-10-x86_64-15'
Compiler: 'Mingw73'
- Features: ['Packaging', 'DisableTests']
+ Features: ['Packaging', 'DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -release -static -nomake tests -nomake examples -no-icu -opengl dynamic -openssl -I %OPENSSL_INCLUDE_x64% -L %OPENSSL_LIB_x64% -plugin-sql-mysql -plugin-sql-sqlite -plugin-sql-odbc -I %MYSQL_INCLUDE_x64% -L %MYSQL_LIB_x64% -platform win32-g++'
-
Template: 'qtci-linux-RHEL-7.6-x86_64'
Compiler: 'GCC'
- Features: ['Packaging', 'DisableTests']
+ Features: ['Packaging', 'DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -release -static -nomake tests -nomake examples -no-use-gold-linker -no-icu -no-fontconfig -qt-freetype -no-opengl -qpa offscreen -no-xcb -qt-libpng -no-vulkan'
diff --git a/coin/platform_configs/qtsdk.yaml b/coin/platform_configs/qtsdk.yaml
index 754e8492..1f1e35d1 100644
--- a/coin/platform_configs/qtsdk.yaml
+++ b/coin/platform_configs/qtsdk.yaml
@@ -2,12 +2,14 @@
Template: 'qtci-windows-10-x86-3'
Compiler: 'MSVC2017'
Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -release -force-debug-info -opengl dynamic -nomake examples -nomake tests'
+ Features: ['UseLegacyInstructions']
-
Template: 'qtci-linux-RHEL-6.6-x86_64'
Compiler: 'GCC'
Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -release -force-debug-info -nomake examples -nomake tests'
+ Features: ['UseLegacyInstructions']
-
Template: 'qtci-windows-8.1-x86'
Compiler: 'MSVC2015'
- Features: ['DisableTests']
+ Features: ['DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -release -force-debug-info -opengl dynamic -nomake examples -nomake tests'
diff --git a/coin/platform_configs/qtsvg.yaml b/coin/platform_configs/qtsvg.yaml
new file mode 100644
index 00000000..a2ac4e29
--- /dev/null
+++ b/coin/platform_configs/qtsvg.yaml
@@ -0,0 +1,30 @@
+Version: 2
+Configurations:
+-
+ Template: 'qtci-linux-Ubuntu-18.04-x86_64'
+ Compiler: 'GCC'
+ Configure arguments: '-DBUILD_EXAMPLES=ON -DFEATURE_developer_build=ON'
+-
+ Template: 'qtci-linux-openSUSE-15.0-x86_64'
+ Compiler: 'GCC'
+ Configure arguments: '-DBUILD_EXAMPLES=OFF -DBUILD_SHARED_LIBS=OFF'
+-
+ Template: 'qtci-macos-10.14-x86_64'
+ Compiler: 'Clang'
+ Configure arguments: '-DBUILD_EXAMPLES=OFF -DCMAKE_OSX_SYSROOT:PATH=/Applications/Xcode11.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk -DCMAKE_OSX_DEPLOYMENT_TARGET=10.14'
+-
+ Template: 'qtci-windows-10-x86_64-15'
+ Compiler: 'MSVC2019'
+ Configure arguments: '-DCMAKE_BUILD_TYPE=RelWithDebInfo -DBUILD_EXAMPLES=OFF -DCMAKE_TOOLCHAIN_FILE={{.Env.VCPKG_ROOT}}/scripts/buildsystems/vcpkg.cmake'
+-
+ Template: 'qtci-linux-RHEL-7.6-x86_64'
+ Compiler: 'GCC'
+ Configure arguments: '-DBUILD_EXAMPLES=OFF'
+-
+ Template: 'qtci-linux-RHEL-7.6-x86_64'
+ Target os: 'Android_ANY'
+ Target arch: 'arm64'
+ Compiler: 'GCC'
+ Target compiler: 'Clang'
+ Configure arguments: '-DBUILD_EXAMPLES=OFF'
+ Environment variables: ['TARGET_CONFIGURE_ARGS=-DBUILD_EXAMPLES=OFF -DCMAKE_TOOLCHAIN_FILE={{.Env.ANDROID_NDK_ROOT}}/build/cmake/android.toolchain.cmake -DANDROID_SDK_ROOT={{.Env.ANDROID_SDK_HOME}} -DANDROID_ABI=arm64-v8a -DVCPKG_TARGET_TRIPLET=arm64-android -DCMAKE_C_COMPILER_FRONTEND_VARIANT=GNU -DCMAKE_CXX_COMPILER_FRONTEND_VARIANT=GNU']
diff --git a/coin/platform_configs/qtwebkit.yaml b/coin/platform_configs/qtwebkit.yaml
index 0a1d5d31..87e6a322 100644
--- a/coin/platform_configs/qtwebkit.yaml
+++ b/coin/platform_configs/qtwebkit.yaml
@@ -1,5 +1,5 @@
-
Template: 'qtci-windows-7-x86-3'
Compiler: 'Mingw73'
- Features: ['Packaging', 'DisableTests']
+ Features: ['Packaging', 'DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -release -nomake tests -nomake examples -opengl dynamic -openssl -I %OPENSSL_INCLUDE_x86% -L %OPENSSL_LIB_x86% -no-sql-mysql -plugin-sql-sqlite -plugin-sql-odbc -I %MYSQL_INCLUDE_x86% -L %MYSQL_LIB_x86% -plugin-sql-psql -I %POSTGRESQL_INCLUDE_x86% -L %POSTGRESQL_LIB_x86% -platform win32-g++'
diff --git a/coin/platform_configs/tqtc-qt-config-gui.yaml b/coin/platform_configs/tqtc-qt-config-gui.yaml
index da37d0e5..70471f1f 100644
--- a/coin/platform_configs/tqtc-qt-config-gui.yaml
+++ b/coin/platform_configs/tqtc-qt-config-gui.yaml
@@ -4,25 +4,25 @@ Configurations:
-
Template: 'qtci-windows-10-x86_64-14'
Compiler: 'MSVC2017'
- Features: ['Packaging']
+ Features: ['Packaging', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -debug-and-release -release -force-debug-info -nomake tests -opengl dynamic -nomake examples -openssl -I %OPENSSL_INCLUDE_x64% -L %OPENSSL_LIB_x64% -no-sql-mysql -plugin-sql-sqlite -plugin-sql-odbc -I %MYSQL_INCLUDE_x64% -L %MYSQL_LIB_x64% -plugin-sql-psql -I %POSTGRESQL_INCLUDE_x64% -L %POSTGRESQL_LIB_x64% -static -no-icu'
-
Template: 'qtci-windows-10-x86_64-14'
Compiler: 'MSVC2017'
Target arch: 'x86'
- Features: ['Packaging']
+ Features: ['Packaging', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -debug-and-release -release -force-debug-info -nomake tests -opengl dynamic -nomake examples -openssl -I %OPENSSL_INCLUDE_x86% -L %OPENSSL_LIB_x86% -no-sql-mysql -plugin-sql-sqlite -plugin-sql-odbc -I %MYSQL_INCLUDE_x86% -L %MYSQL_LIB_x86% -plugin-sql-psql -I %POSTGRESQL_INCLUDE_x86% -L %POSTGRESQL_LIB_x86% -static -no-icu'
-
Template: 'qtci-linux-RHEL-7.6-x86_64'
Compiler: 'GCC'
- Features: ['Packaging']
+ Features: ['Packaging', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /home/qt/work/install -release -nomake tests -nomake examples -no-libudev -no-use-gold-linker -force-debug-info -no-sql-mysql -plugin-sql-psql -plugin-sql-sqlite -qt-libjpeg -qt-libpng -qt-xcb -sysconfdir /etc/xdg -qt-pcre -qt-harfbuzz -openssl -I {{.Env.OPENSSL_HOME}}/include -L {{.Env.OPENSSL_HOME}}/lib QMAKE_LFLAGS_APP+=-s -static -no-icu'
-
Template: 'qtci-macos-10.13-x86_64-2'
Compiler: 'Clang'
- Features: ['Packaging']
+ Features: ['Packaging', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /Users/qt/work/install -debug-and-release -release -nomake tests -nomake examples -no-sql-mysql -plugin-sql-psql -plugin-sql-sqlite -sysconfdir /Library/Preferences/Qt -I/usr/local/opt/openssl/include -static -no-icu'
-
Template: 'qtci-linux-Ubuntu-18.04-x86_64'
Compiler: 'GCC'
- Features: ['TestOnly', 'LicenseCheck']
+ Features: ['TestOnly', 'LicenseCheck', 'UseLegacyInstructions']
diff --git a/coin/platform_configs/tqtc-qt-rta.yaml b/coin/platform_configs/tqtc-qt-rta.yaml
index 76664d06..5f72bc29 100644
--- a/coin/platform_configs/tqtc-qt-rta.yaml
+++ b/coin/platform_configs/tqtc-qt-rta.yaml
@@ -1,14 +1,15 @@
-
Template: 'qtci-windows-7-x86_64-4'
Compiler: 'MSVC2013'
- Features: ['DisableTests']
+ Features: ['DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -release -force-debug-info -opengl dynamic -nomake examples -nomake tests'
-
Template: 'qtci-windows-8.1-x86_64'
Compiler: 'MSVC2013'
- Features: ['DisableTests']
+ Features: ['DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -release -force-debug-info -opengl dynamic -nomake examples -nomake tests'
-
Template: 'qtci-windows-10-x86-3'
Compiler: 'MSVC2017'
Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -release -force-debug-info -opengl dynamic -nomake examples -nomake tests'
+ Features: ['UseLegacyInstructions']
diff --git a/coin/provisioning/common/linux/cmake_linux.sh b/coin/provisioning/common/linux/cmake_linux.sh
index a3b2a9cc..f03bd16c 100755
--- a/coin/provisioning/common/linux/cmake_linux.sh
+++ b/coin/provisioning/common/linux/cmake_linux.sh
@@ -33,7 +33,7 @@
##
#############################################################################
-# This script installs CMake 3.7.2
+# This script installs CMake
# CMake is needed for autotests that verify that Qt can be built with CMake
@@ -42,10 +42,11 @@ source "${BASH_SOURCE%/*}/../unix/InstallFromCompressedFileFromURL.sh"
# shellcheck source=../unix/SetEnvVar.sh
source "${BASH_SOURCE%/*}/../unix/SetEnvVar.sh"
-version="3.7.2"
-PrimaryUrl="http://ci-files01-hki.intra.qt.io/input/cmake/cmake-3.7.2-Linux-x86_64.tar.gz"
-AltUrl="https://cmake.org/files/v3.7/cmake-3.7.2-Linux-x86_64.tar.gz"
-SHA1="915bc981aab354821fb9fd28374a720fdb3aa180"
+majorminorversion="3.16"
+version="3.16.0-rc4"
+PrimaryUrl="http://ci-files01-hki.intra.qt.io/input/cmake/cmake-$version-Linux-x86_64.tar.gz"
+AltUrl="https://cmake.org/files/v$majorminorversion/cmake-$version-Linux-x86_64.tar.gz"
+SHA1="def260a8f27d3b1b9c3d042ec936236598bea52a"
targetFolder="/opt/cmake-$version"
appPrefix="cmake-$version-Linux-x86_64"
diff --git a/coin/provisioning/common/linux/vcpkg.sh b/coin/provisioning/common/linux/vcpkg.sh
new file mode 100755
index 00000000..35f2ece8
--- /dev/null
+++ b/coin/provisioning/common/linux/vcpkg.sh
@@ -0,0 +1,73 @@
+#!/usr/bin/env bash
+
+#############################################################################
+##
+## Copyright (C) 2019 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the provisioning scripts of the Qt Toolkit.
+##
+## $QT_BEGIN_LICENSE:LGPL21$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see http://www.qt.io/terms-conditions. For further
+## information use the contact form at http://www.qt.io/contact-us.
+##
+## GNU Lesser General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU Lesser
+## General Public License version 2.1 or version 3 as published by the Free
+## Software Foundation and appearing in the file LICENSE.LGPLv21 and
+## LICENSE.LGPLv3 included in the packaging of this file. Please review the
+## following information to ensure the GNU Lesser General Public License
+## requirements will be met: https://www.gnu.org/licenses/lgpl.html and
+## http://www.gnu.org/licenses/old-licenses/lgpl-2.1.html.
+##
+## As a special exception, The Qt Company gives you certain additional
+## rights. These rights are described in The Qt Company LGPL Exception
+## version 1.1, included in the file LGPL_EXCEPTION.txt in this package.
+##
+## $QT_END_LICENSE$
+##
+#############################################################################
+
+set -ex
+
+source "${BASH_SOURCE%/*}/../unix/SetEnvVar.sh"
+
+# This script installs VcPkg. It is used to provide third-party libraries when cross-compiling
+# for example for Emscripten or Android.
+
+# Refresh to make sure we have the EMSCRIPTEN environment variable, needed for the vcpkg wasm build.
+source ~/.bashrc
+
+source "${BASH_SOURCE%/*}/../shared/vcpkg_version.txt"
+
+officialUrl="https://codeload.github.com/tronical/vcpkg/tar.gz/$vcpkg_version"
+targetFile="vcpkg.tar.gz"
+targetFolder="$HOME/vcpkg"
+
+wget --tries=5 --waitretry=5 --progress=dot:giga --output-document="$targetFile" "$officialUrl"
+
+if [ ! -d "${targetFolder}" ]; then
+ mkdir -p $targetFolder
+fi
+
+tar -C $targetFolder --strip-components=1 -xvzf $targetFile
+rm -rf $targetFile
+
+SetEnvVar "VCPKG_ROOT" "$targetFolder"
+
+cd $targetFolder
+./bootstrap-vcpkg.sh
+
+./vcpkg install --triplet arm-android @qt-packages-android.txt
+./vcpkg install --triplet arm64-android @qt-packages-android.txt
+./vcpkg install --triplet x86-android @qt-packages-android.txt
+./vcpkg install --triplet x64-android @qt-packages-android.txt
+
+rm -rf packages buildtrees downloads
+
+echo "VCPKG = $vcpkg_version" >> ~/versions.txt
diff --git a/coin/provisioning/common/macos/cmake.sh b/coin/provisioning/common/macos/cmake.sh
index e22425b7..8e20586b 100755
--- a/coin/provisioning/common/macos/cmake.sh
+++ b/coin/provisioning/common/macos/cmake.sh
@@ -42,13 +42,15 @@ source "${BASH_SOURCE%/*}/InstallAppFromCompressedFileFromURL.sh"
# shellcheck source=../unix/SetEnvVar.sh
source "${BASH_SOURCE%/*}/../unix/SetEnvVar.sh"
-PrimaryUrl="http://ci-files01-hki.intra.qt.io/input/mac/macos_10.13_high_sierra/cmake-3.11.3-Darwin-x86_64.tar.gz"
-AltUrl="https://cmake.org/files/v3.11/cmake-3.11.3-Darwin-x86_64.tar.gz"
-SHA1="3d13de8020ce560159fa5cecb669498c48552d96"
-appPrefix="cmake-3.11.3-Darwin-x86_64"
+majorminorversion="3.16"
+version="3.16.0-rc4"
+PrimaryUrl="http://ci-files01-hki.intra.qt.io/input/cmake/cmake-$version-Darwin-x86_64.tar.gz"
+AltUrl="https://cmake.org/files/v$majorminorversion/cmake-$version-Darwin-x86_64.tar.gz"
+SHA1="a2727f4f01329b5b8154840e9ba0de37e3fb14d5"
+appPrefix="cmake-$version-Darwin-x86_64"
InstallAppFromCompressedFileFromURL "$PrimaryUrl" "$AltUrl" "$SHA1" "$appPrefix"
SetEnvVar "PATH" "/Applications/CMake.app/Contents/bin:\$PATH"
-echo "CMake = 3.11.3" >> ~/versions.txt
+echo "CMake = $version" >> ~/versions.txt
diff --git a/coin/provisioning/common/macos/python3.sh b/coin/provisioning/common/macos/python3.sh
index 35bccc93..185c3b01 100755
--- a/coin/provisioning/common/macos/python3.sh
+++ b/coin/provisioning/common/macos/python3.sh
@@ -2,7 +2,7 @@
#############################################################################
##
-## Copyright (C) 2017 The Qt Company Ltd.
+## Copyright (C) 2019 The Qt Company Ltd.
## Copyright (C) 2017 Pelagicore AG
## Contact: http://www.qt.io/licensing/
##
@@ -43,23 +43,23 @@ source "${BASH_SOURCE%/*}/../unix/SetEnvVar.sh"
# shellcheck source=./pip.sh
source "${BASH_SOURCE%/*}/pip.sh"
-PrimaryUrl="http://ci-files01-hki.intra.qt.io/input/mac/python-3.6.1-macosx10.6.pkg"
-AltUrl="https://www.python.org/ftp/python/3.6.1/python-3.6.1-macosx10.6.pkg"
-SHA1="ae0c749544c2d573c3cc29c4c2d7d9a595db28f9"
+PrimaryUrl="http://ci-files01-hki.intra.qt.io/input/mac/python-3.7.4-macosx10.9.pkg"
+AltUrl="https://www.python.org/ftp/python/3.7.4/python-3.7.4-macosx10.9.pkg"
+SHA1="ef8a6b1abba6a6e8553916a881af440705653fa8"
DestDir="/"
InstallPKGFromURL "$PrimaryUrl" "$AltUrl" "$SHA1" "$DestDir"
-InstallPip python3.6
+InstallPip python3.7
-/Library/Frameworks/Python.framework/Versions/3.6/bin/pip3 install virtualenv wheel
+/Library/Frameworks/Python.framework/Versions/3.7/bin/pip3 install virtualenv wheel
-SetEnvVar "PYTHON3_PATH" "/Library/Frameworks/Python.framework/Versions/3.6/bin"
-SetEnvVar "PIP3_PATH" "/Library/Frameworks/Python.framework/Versions/3.6/bin"
+SetEnvVar "PYTHON3_PATH" "/Library/Frameworks/Python.framework/Versions/3.7/bin"
+SetEnvVar "PIP3_PATH" "/Library/Frameworks/Python.framework/Versions/3.7/bin"
# Install all needed packages in a special wheel cache directory
-/Library/Frameworks/Python.framework/Versions/3.6/bin/pip3 wheel --wheel-dir $HOME/python3-wheels -r ${BASH_SOURCE%/*}/../shared/requirements.txt
+/Library/Frameworks/Python.framework/Versions/3.7/bin/pip3 wheel --wheel-dir $HOME/python3-wheels -r ${BASH_SOURCE%/*}/../shared/requirements.txt
SetEnvVar "PYTHON3_WHEEL_CACHE" "$HOME/python3-wheels"
-echo "python3 = 3.6.1" >> ~/versions.txt
+echo "python3 = 3.7.4" >> ~/versions.txt
diff --git a/coin/provisioning/common/shared/vcpkg_version.txt b/coin/provisioning/common/shared/vcpkg_version.txt
new file mode 100644
index 00000000..7bff414a
--- /dev/null
+++ b/coin/provisioning/common/shared/vcpkg_version.txt
@@ -0,0 +1 @@
+vcpkg_version=qt-snapshot-2019-12-05
diff --git a/coin/provisioning/common/unix/install_protobuff.sh b/coin/provisioning/common/unix/install_protobuff.sh
index a9b2cfd0..9a1d9508 100755
--- a/coin/provisioning/common/unix/install_protobuff.sh
+++ b/coin/provisioning/common/unix/install_protobuff.sh
@@ -53,7 +53,7 @@ sudo rm "$targetFile"
# devtoolset is needed when running configuration
if uname -a |grep -qv "Darwin"; then
- export PATH="/opt/rh/devtoolset-4/root/usr/bin:$PATH"
+ export PATH="/opt/rh/devtoolset-7/root/usr/bin:$PATH"
fi
echo "Configuring and building protobuf"
diff --git a/coin/provisioning/common/windows/cmake.ps1 b/coin/provisioning/common/windows/cmake.ps1
index 9d3d6aef..bbec4b4f 100644
--- a/coin/provisioning/common/windows/cmake.ps1
+++ b/coin/provisioning/common/windows/cmake.ps1
@@ -1,6 +1,6 @@
#############################################################################
##
-## Copyright (C) 2017 The Qt Company Ltd.
+## Copyright (C) 2019 The Qt Company Ltd.
## Contact: http://www.qt.io/licensing/
##
## This file is part of the provisioning scripts of the Qt Toolkit.
@@ -33,8 +33,8 @@
. "$PSScriptRoot\helpers.ps1"
-$majorminorversion = "3.7"
-$version = "3.7.2"
+$majorminorversion = "3.16"
+$version = "3.16.0-rc4"
$zip = Get-DownloadLocation ("cmake-" + $version + "-win32-x86.zip")
$officialurl = "https://cmake.org/files/v" + $majorminorversion + "/cmake-" + $version + "-win32-x86.zip"
@@ -44,7 +44,7 @@ Write-Host "Removing old cmake"
Remove-Item "C:\CMake" -Force -Recurse -ErrorAction SilentlyContinue
Download $officialurl $cachedurl $zip
-Verify-Checksum $zip "c80c17e858ecfebfaf16fe8af18b174d2600c4e6"
+Verify-Checksum $zip "989e5c6384870a77425f2ddbbf305bd3f6dad426"
Extract-7Zip $zip C:
$defaultinstallfolder = "C:\cmake-" + $version + "-win32-x86"
diff --git a/coin/provisioning/common/windows/install-vcpkg.ps1 b/coin/provisioning/common/windows/install-vcpkg.ps1
new file mode 100644
index 00000000..52f1518f
--- /dev/null
+++ b/coin/provisioning/common/windows/install-vcpkg.ps1
@@ -0,0 +1,69 @@
+#############################################################################
+##
+## Copyright (C) 2019 The Qt Company Ltd.
+## Contact: http://www.qt.io/licensing/
+##
+## This file is part of the provisioning scripts of the Qt Toolkit.
+##
+## $QT_BEGIN_LICENSE:LGPL21$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see http://www.qt.io/terms-conditions. For further
+## information use the contact form at http://www.qt.io/contact-us.
+##
+## GNU Lesser General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU Lesser
+## General Public License version 2.1 or version 3 as published by the Free
+## Software Foundation and appearing in the file LICENSE.LGPLv21 and
+## LICENSE.LGPLv3 included in the packaging of this file. Please review the
+## following information to ensure the GNU Lesser General Public License
+## requirements will be met: https://www.gnu.org/licenses/lgpl.html and
+## http://www.gnu.org/licenses/old-licenses/lgpl-2.1.html.
+##
+## As a special exception, The Qt Company gives you certain additional
+## rights. These rights are described in The Qt Company LGPL Exception
+## version 1.1, included in the file LGPL_EXCEPTION.txt in this package.
+##
+## $QT_END_LICENSE$
+##
+#############################################################################
+. "$PSScriptRoot\helpers.ps1"
+
+# This script will install vcpkg
+
+Write-Host "Installing vcpkg"
+
+$n = Get-Content "$PSScriptRoot\..\shared\vcpkg_version.txt"
+$n = $n.Split('=')
+New-Variable -Name $n[0] -Value $n[1]
+
+$officialUrl = "https://codeload.github.com/tronical/vcpkg/zip/$vcpkg_version"
+$zip = "C:\Utils\vcpkg.zip"
+
+Download "$officialUrl" "" "$zip"
+Extract-7Zip "$zip" c:\utils
+Remove-Item $zip
+
+$installationFolder = "c:\utils\vcpkg-$vcpkg_version"
+
+cd $installationFolder
+
+cmd /c bootstrap-vcpkg.bat
+
+if(![System.IO.File]::Exists("$installationFolder\vcpkg.exe")){
+ Write-Host "Can't find $installationFolder\vcpkg.exe. Installation probably failed!"
+ exit 1
+}
+
+Set-EnvironmentVariable VCPKG_DEFAULT_TRIPLET "qt-x64-windows-static"
+Set-EnvironmentVariable VCPKG_ROOT "$installationFolder"
+
+cmd /c $installationFolder\vcpkg.exe install --triplet qt-x64-windows-static @qt-packages-windows.txt
+cmd /c $installationFolder\vcpkg.exe install --triplet qt-x86-windows-static @qt-packages-windows.txt
+
+Remove-Item -Recurse -Force packages
+Remove-Item -Recurse -Force buildtrees
+Remove-Item -Recurse -Force downloads
diff --git a/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/03-install-devtoolset.sh b/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/03-install-devtoolset.sh
index ebc7cac6..5d37a53a 100755
--- a/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/03-install-devtoolset.sh
+++ b/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/03-install-devtoolset.sh
@@ -35,7 +35,7 @@
set -ex
-sudo yum -y install devtoolset-4
+sudo yum -y install devtoolset-7
-echo "source /opt/rh/devtoolset-4/enable" >> ~/.bashrc
+echo "source /opt/rh/devtoolset-7/enable" >> ~/.bashrc
diff --git a/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/04-install-packages.sh b/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/04-install-packages.sh
index b956d6a3..6b569552 100755
--- a/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/04-install-packages.sh
+++ b/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/04-install-packages.sh
@@ -38,13 +38,20 @@ set -ex
# Remove update notifications and packagekit running in the background
sudo yum -y remove PackageKit gnome-software
+sudo yum-config-manager --enable rhel-server-rhscl-7-rpms
+
installPackages=()
-installPackages+=(git)
+installPackages+=(rh-git29)
installPackages+=(zlib-devel)
installPackages+=(glib2-devel)
installPackages+=(openssl-devel)
installPackages+=(freetype-devel)
installPackages+=(fontconfig-devel)
+# cmake build
+installPackages+=(ninja-build)
+installPackages+=(pcre2-devel)
+installPackages+=(double-conversion-devel)
+installPackages+=(zstd)
# EGL support
installPackages+=(mesa-libEGL-devel)
installPackages+=(mesa-libGL-devel)
@@ -118,6 +125,9 @@ installPackages+=(vulkan-devel)
sudo yum -y install "${installPackages[@]}"
+scl enable rh-git29 bash
+sudo ln -s /opt/rh/rh-git29/root/usr/bin/git /usr/local/bin/git
+
sudo ln -s /opt/rh/rh-python36/root/usr/bin/python3 /usr/local/bin/python3
sudo ln -s /opt/rh/rh-python36/root/usr/bin/pip3 /usr/local/bin/pip3
# We shouldn't use yum to install virtualenv. The one found from package repo is not
diff --git a/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/06-cmake.sh b/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/40-install-cmake.sh
index 062b2790..062b2790 100755
--- a/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/06-cmake.sh
+++ b/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/40-install-cmake.sh
diff --git a/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/56-vcpkg.sh b/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/56-vcpkg.sh
new file mode 100755
index 00000000..5c7f3f1d
--- /dev/null
+++ b/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/56-vcpkg.sh
@@ -0,0 +1,5 @@
+#!/usr/bin/env bash
+
+set -ex
+
+"$(dirname "$0")/../common/linux/vcpkg.sh"
diff --git a/coin/provisioning/qtci-linux-SLES-15-x86_64/02-zypperpackages.sh b/coin/provisioning/qtci-linux-SLES-15-x86_64/02-zypperpackages.sh
index 080bc43b..7c9520d7 100755
--- a/coin/provisioning/qtci-linux-SLES-15-x86_64/02-zypperpackages.sh
+++ b/coin/provisioning/qtci-linux-SLES-15-x86_64/02-zypperpackages.sh
@@ -35,7 +35,7 @@
set -ex
-sudo zypper -nq install git gcc gcc-c++
+sudo zypper -nq install git gcc gcc-c++ ninja
sudo zypper -nq install bison flex gperf \
zlib-devel \
diff --git a/coin/provisioning/qtci-linux-Ubuntu-18.04-x86_64/02-apt.sh b/coin/provisioning/qtci-linux-Ubuntu-18.04-x86_64/02-apt.sh
index d5f9ef7a..15d41b8a 100755
--- a/coin/provisioning/qtci-linux-Ubuntu-18.04-x86_64/02-apt.sh
+++ b/coin/provisioning/qtci-linux-Ubuntu-18.04-x86_64/02-apt.sh
@@ -171,6 +171,12 @@ installPackages+=(gawk)
installPackages+=(texinfo)
# Needed for Poppler test in QtWebEngine
installPackages+=(libpoppler-cpp-dev)
+# Needed for QtCore
+installPackages+=(libdouble-conversion-dev)
+installPackages+=(libpcre2-dev)
+# Needed for qtgampepad
+installPackages+=(libsdl2-2.0)
+installPackages+=(libsdl2-dev)
echo "Running update for apt"
waitLoop
diff --git a/coin/provisioning/qtci-linux-Ubuntu-18.04-x86_64/40-cmake.sh b/coin/provisioning/qtci-linux-Ubuntu-18.04-x86_64/40-install-cmake.sh
index db8a3ff5..db8a3ff5 100755
--- a/coin/provisioning/qtci-linux-Ubuntu-18.04-x86_64/40-cmake.sh
+++ b/coin/provisioning/qtci-linux-Ubuntu-18.04-x86_64/40-install-cmake.sh
diff --git a/coin/provisioning/qtci-linux-openSUSE-15.0-x86_64/02-zypperpackages.sh b/coin/provisioning/qtci-linux-openSUSE-15.0-x86_64/02-zypperpackages.sh
index d1f3050f..9da9ed0f 100755
--- a/coin/provisioning/qtci-linux-openSUSE-15.0-x86_64/02-zypperpackages.sh
+++ b/coin/provisioning/qtci-linux-openSUSE-15.0-x86_64/02-zypperpackages.sh
@@ -2,7 +2,7 @@
set -ex
-sudo zypper -nq install git gcc7 gcc7-c++
+sudo zypper -nq install git gcc7 gcc7-c++ ninja
sudo /usr/sbin/update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-7 1 \
--slave /usr/bin/g++ g++ /usr/bin/g++-7 \
--slave /usr/bin/cc cc /usr/bin/gcc-7 \
@@ -17,7 +17,8 @@ sudo zypper -nq install bison flex gperf \
fontconfig-devel \
sqlite3-devel \
libxkbcommon-devel \
- libxkbcommon-x11-devel
+ libxkbcommon-x11-devel \
+ pcre2-devel libpng16-devel
# EGL support
sudo zypper -nq install Mesa-libEGL-devel Mesa-libGL-devel
diff --git a/coin/provisioning/qtci-macos-10.13-x86_64/25-cmake.sh b/coin/provisioning/qtci-macos-10.13-x86_64/25-install-cmake.sh
index 4f4d405e..4f4d405e 100755
--- a/coin/provisioning/qtci-macos-10.13-x86_64/25-cmake.sh
+++ b/coin/provisioning/qtci-macos-10.13-x86_64/25-install-cmake.sh
diff --git a/coin/provisioning/qtci-macos-10.13-x86_64/26-freetype.sh b/coin/provisioning/qtci-macos-10.13-x86_64/26-freetype.sh
new file mode 100755
index 00000000..0faec4b4
--- /dev/null
+++ b/coin/provisioning/qtci-macos-10.13-x86_64/26-freetype.sh
@@ -0,0 +1,5 @@
+#!/usr/bin/env bash
+
+set -ex
+
+brew install freetype
diff --git a/coin/provisioning/qtci-macos-10.13-x86_64/26-ninja.sh b/coin/provisioning/qtci-macos-10.13-x86_64/26-ninja.sh
new file mode 100755
index 00000000..c9d3e309
--- /dev/null
+++ b/coin/provisioning/qtci-macos-10.13-x86_64/26-ninja.sh
@@ -0,0 +1,5 @@
+#!/usr/bin/env bash
+
+set -ex
+
+brew install ninja
diff --git a/coin/provisioning/qtci-macos-10.13-x86_64/26-pcre2.sh b/coin/provisioning/qtci-macos-10.13-x86_64/26-pcre2.sh
new file mode 100755
index 00000000..f8af516b
--- /dev/null
+++ b/coin/provisioning/qtci-macos-10.13-x86_64/26-pcre2.sh
@@ -0,0 +1,5 @@
+#!/usr/bin/env bash
+
+set -ex
+
+brew install pcre2
diff --git a/coin/provisioning/qtci-macos-10.14-x86_64/26-freetype.sh b/coin/provisioning/qtci-macos-10.14-x86_64/26-freetype.sh
new file mode 100755
index 00000000..0faec4b4
--- /dev/null
+++ b/coin/provisioning/qtci-macos-10.14-x86_64/26-freetype.sh
@@ -0,0 +1,5 @@
+#!/usr/bin/env bash
+
+set -ex
+
+brew install freetype
diff --git a/coin/provisioning/qtci-macos-10.14-x86_64/26-ninja.sh b/coin/provisioning/qtci-macos-10.14-x86_64/26-ninja.sh
new file mode 100755
index 00000000..c9d3e309
--- /dev/null
+++ b/coin/provisioning/qtci-macos-10.14-x86_64/26-ninja.sh
@@ -0,0 +1,5 @@
+#!/usr/bin/env bash
+
+set -ex
+
+brew install ninja
diff --git a/coin/provisioning/qtci-macos-10.14-x86_64/26-pcre2.sh b/coin/provisioning/qtci-macos-10.14-x86_64/26-pcre2.sh
new file mode 100755
index 00000000..f8af516b
--- /dev/null
+++ b/coin/provisioning/qtci-macos-10.14-x86_64/26-pcre2.sh
@@ -0,0 +1,5 @@
+#!/usr/bin/env bash
+
+set -ex
+
+brew install pcre2
diff --git a/coin/provisioning/qtci-windows-10-x86_64/90-install-vcpkg.ps1 b/coin/provisioning/qtci-windows-10-x86_64/90-install-vcpkg.ps1
new file mode 100644
index 00000000..c898da22
--- /dev/null
+++ b/coin/provisioning/qtci-windows-10-x86_64/90-install-vcpkg.ps1
@@ -0,0 +1,2 @@
+. "$PSScriptRoot\..\common\windows\install-vcpkg.ps1"
+