summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2020-04-28 12:21:03 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2020-05-12 09:11:33 +0200
commit0f1ff389235018f51c3a5e287896bc4ee3e7c1e9 (patch)
tree32891bdbc417fa78f0a1761605b92c917a4eb0cb /CMakeLists.txt
parenta8284209f33eee8a5ecdbb2cce7798e689bc8b5d (diff)
Initial port to cmake
Port the 2 main libraries, examples and tests. Task-number: QTBUG-78167 Change-Id: I0d00c9fa352a96dcd0e1f42d52e6f15680abd9ed Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..14352ff
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,20 @@
+# Generated from qtactiveqt.pro.
+
+cmake_minimum_required(VERSION 3.15.0)
+
+include(".cmake.conf")
+project(QtActiveQt # special case
+ VERSION "${QT_REPO_MODULE_VERSION}"
+ DESCRIPTION "Qt Active Qt Libraries" # special case
+ HOMEPAGE_URL "https://qt.io/"
+ LANGUAGES CXX C
+)
+
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Widgets PrintSupport) # special case
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Qml Quick) # special case
+
+if(NOT TARGET Qt::Widgets)
+ message(NOTICE "Skipping the build as the condition \"TARGET Qt::Widgets\" is not met.")
+ return()
+endif()
+qt_build_repo()