summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2021-04-08 12:00:12 +0200
committerAlexey Edelev <alexey.edelev@qt.io>2021-04-12 16:44:56 +0200
commit664e467c1eb03f537d9d477bcc99ffd101fc1943 (patch)
tree682c44c007863f11a1c494c900952c3dd13e724d /CMakeLists.txt
parent363068f57525e808aa20cb8dbcffdc13f6712df1 (diff)
Fix manual tests
Restore the path definition to the diaglib test library and fix its usage. Add optional dependency on OpenGL OpenGLWidgets for the axviewer manual test. Pick-to: 6.1 6.1.0 Change-Id: If7692172a498556c616f78f7d477d8e3b126faed Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b04e4fe..090750b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,8 +23,11 @@ if (NOT WIN32)
endif()
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core) # special case
-find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Qml Quick Gui Widgets PrintSupport) # special case
-
+# special case begin
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Qml Quick Gui Widgets
+ PrintSupport OpenGL OpenGLWidgets
+)
+# special case end
if(NOT TARGET Qt::Gui OR NOT TARGET Qt::Widgets OR NOT TARGET Qt::PrintSupport)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Gui\", \"TARGET Qt::Widget\" "
"or \"TARGET Qt::Printsupport\" is not met.")