summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2021-03-11 19:13:03 +0100
committerAlexey Edelev <alexey.edelev@qt.io>2021-03-23 13:10:08 +0100
commitb8935eca5625be034632200adcccf18a398f67a2 (patch)
tree4dc4117a1383dc71f4292248119910dba2d8184e /CMakeLists.txt
parent2b2de60a369ba195703435328fc3812dbef430e5 (diff)
Add qt6_target_typelibs function
qt6_target_typelibs should replace the qmake functionality associated with the TYPELIBS variable. This function adds custom call of the dumpcpp program to generate typelib-related sources and adds the sources to the target. Pick-to: 6.1 Task-number: QTBUG-78167 Change-Id: I7b61a2b1804162e723e862945a9650a00776e678 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 392016c..b04e4fe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -31,4 +31,6 @@ if(NOT TARGET Qt::Gui OR NOT TARGET Qt::Widgets OR NOT TARGET Qt::PrintSupport)
return()
endif()
+include("${CMAKE_CURRENT_SOURCE_DIR}/src/activeqt/container/Qt6AxContainerMacros.cmake")
+
qt_build_repo()