summaryrefslogtreecommitdiffstats
path: root/examples/activeqt/menus/CMakeLists.txt
diff options
context:
space:
mode:
authorOliver Wolff <oliver.wolff@qt.io>2023-04-03 09:45:20 +0200
committerOliver Wolff <oliver.wolff@qt.io>2023-04-06 10:36:17 +0200
commit73f52eb39f80ce2ba9602c3faf8939b752aa9098 (patch)
treeb1889fb77079412bdb9b3c002a346fea5e94083a /examples/activeqt/menus/CMakeLists.txt
parent4fa7ebcf6390ed415ffd8d6bdc4987b789dad309 (diff)
examples: Remove menus example
Showing the usage of QMenuBar and QStatusBar in a QMainWindow can be merged into another if needed. In order to keep the use case's code in source, the example was moved to tests/manual. Pick-to: 6.5 Change-Id: I76ec12e9c83a42028f2de95ab17ca07544b53425 Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'examples/activeqt/menus/CMakeLists.txt')
-rw-r--r--examples/activeqt/menus/CMakeLists.txt34
1 files changed, 0 insertions, 34 deletions
diff --git a/examples/activeqt/menus/CMakeLists.txt b/examples/activeqt/menus/CMakeLists.txt
deleted file mode 100644
index bb06f93..0000000
--- a/examples/activeqt/menus/CMakeLists.txt
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
-
-cmake_minimum_required(VERSION 3.16)
-project(menusax LANGUAGES CXX)
-
-set(CMAKE_AUTOMOC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/activeqt/menus")
-
-find_package(Qt6 REQUIRED COMPONENTS AxServer Core Gui Widgets)
-
-qt6_add_axserver_executable(menusax
- main.cpp
- menus.cpp menus.h
- menus.def
- menus.rc
-)
-
-target_link_libraries(menusax PUBLIC
- Qt::Core
- Qt::Gui
- Qt::Widgets
-)
-
-install(TARGETS menusax
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)