summaryrefslogtreecommitdiffstats
path: root/src/activeqt/container/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2020-05-13 08:05:39 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2020-05-28 07:48:53 +0200
commit592dcba7276b129220a27af3bef44a736ca347ba (patch)
treeb5d19d615a54ff109f3fce0bea71589f971a3416 /src/activeqt/container/CMakeLists.txt
parent9bd2e8f1cc1f98a0fb613e20a971e9eee22e19ae (diff)
Remove hard-coded QMetaObject data
Introduce QAxBaseObject and QAxBaseWidget providing the static properties and signals of QAxObject and QAxWidget. Rename the QAxBase methods to be called from the metacall implementations of QAxObject and QAxWidget. Add "classContext" as a real property on this occasion. Change-Id: Ia4f4e45e091e2d575ed9e6b2dd212139a1146300 Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'src/activeqt/container/CMakeLists.txt')
-rw-r--r--src/activeqt/container/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/activeqt/container/CMakeLists.txt b/src/activeqt/container/CMakeLists.txt
index f9b72b4..ddb16d8 100644
--- a/src/activeqt/container/CMakeLists.txt
+++ b/src/activeqt/container/CMakeLists.txt
@@ -13,6 +13,7 @@ qt_add_module(AxContainer
qaxbase.cpp qaxbase.h qaxbase_p.h
qaxdump.cpp
qaxobject.cpp qaxobject.h
+ qaxobjectinterface.h
qaxscript.cpp qaxscript.h
qaxscriptwrapper.cpp
qaxselect.cpp qaxselect.h qaxselect.ui