summaryrefslogtreecommitdiffstats
path: root/src/activeqt/container/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2023-11-28 14:47:23 +0100
committerAlexey Edelev <alexey.edelev@qt.io>2024-03-14 09:12:14 +0100
commite5d7c15086bfb6e694207a020fec6dab59199320 (patch)
tree61632b2f3cd4ae7b24a43193ea7ae27835bc5bb7 /src/activeqt/container/CMakeLists.txt
parent2606ee612dea16109a5e4e0fc2e9dcb599fd7c52 (diff)
Use NO_GENERATE_CPP_EXPORTS explicitly
Use NO_GENERATE_CPP_EXPORTS explicitly for modules that don't need the autogenerated exports header file. Task-number: QTBUG-90492 Change-Id: I93fd582f2dbec7ac59958c3d3d5d2d733033a4e5 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Oliver Wolff <oliver.wolff@qt.io>
Diffstat (limited to 'src/activeqt/container/CMakeLists.txt')
-rw-r--r--src/activeqt/container/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/activeqt/container/CMakeLists.txt b/src/activeqt/container/CMakeLists.txt
index 717b0f4..6458d3e 100644
--- a/src/activeqt/container/CMakeLists.txt
+++ b/src/activeqt/container/CMakeLists.txt
@@ -30,6 +30,7 @@ qt_internal_add_module(AxContainer
Qt::Widgets
ENABLE_AUTOGEN_TOOLS
uic
+ NO_GENERATE_CPP_EXPORTS
)
set_source_files_properties(qaxbase.cpp # defines QT_CHECK_STATE