summaryrefslogtreecommitdiffstats
path: root/src/activeqt/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorTopi Reinio <topi.reinio@qt.io>2021-04-15 12:31:05 +0200
committerTopi Reiniƶ <topi.reinio@qt.io>2021-04-16 07:11:36 +0000
commitff72ae1903e9b303e7fdc9572ae829be9f3af9e3 (patch)
treef6b5192a71982e24ede5562ed421d56e99013c79 /src/activeqt/doc/CMakeLists.txt
parent0d12b5359800727dde28ddcd92892fdc5c2a736a (diff)
Doc: Fix documentation warnings
* Add a dependency to QtCore for the documentation target; required to pull in Qt-specific include paths for QDoc * Fix minor issues, mostly linking to items Pick-to: 6.1 Task-number: QTBUG-91875 Change-Id: Ia99c4e417af15da4e8ac66d14d07f23e83690088 Reviewed-by: Paul Wicking <paul.wicking@qt.io>
Diffstat (limited to 'src/activeqt/doc/CMakeLists.txt')
-rw-r--r--src/activeqt/doc/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/activeqt/doc/CMakeLists.txt b/src/activeqt/doc/CMakeLists.txt
index ef28015..94b3c4d 100644
--- a/src/activeqt/doc/CMakeLists.txt
+++ b/src/activeqt/doc/CMakeLists.txt
@@ -1,4 +1,5 @@
# special case skip regeneration
add_library(ActiveQt INTERFACE)
+target_link_libraries(ActiveQt INTERFACE Qt::Core)
qt_internal_add_docs(ActiveQt activeqt.qdocconf)