summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1a647f6..bfddcf2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,14 +1,12 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
-# Generated from qtactiveqt.pro.
-
cmake_minimum_required(VERSION 3.16)
include(".cmake.conf")
-project(QtActiveQt # special case
+project(QtActiveQt
VERSION "${QT_REPO_MODULE_VERSION}"
- DESCRIPTION "Qt Active Qt Libraries" # special case
+ DESCRIPTION "Qt Active Qt Libraries"
HOMEPAGE_URL "https://qt.io/"
LANGUAGES CXX C
)
@@ -18,6 +16,8 @@ if (NOT WIN32)
# special case begin
set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals)
+ qt_internal_project_setup()
+
qt_build_repo_begin()
add_subdirectory(src/activeqt/doc)
qt_build_repo_end()
@@ -25,12 +25,12 @@ if (NOT WIN32)
return()
endif()
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core) # special case
-# special case begin
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Qml Quick Gui Widgets
PrintSupport OpenGL OpenGLWidgets
)
-# special case end
+qt_internal_project_setup()
+
if(NOT TARGET Qt::Gui OR NOT TARGET Qt::Widgets OR NOT TARGET Qt::PrintSupport)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Gui\", \"TARGET Qt::Widget\" "
"or \"TARGET Qt::Printsupport\" is not met.")