summaryrefslogtreecommitdiffstats
path: root/examples/activeqt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/activeqt/CMakeLists.txt')
-rw-r--r--examples/activeqt/CMakeLists.txt21
1 files changed, 6 insertions, 15 deletions
diff --git a/examples/activeqt/CMakeLists.txt b/examples/activeqt/CMakeLists.txt
index c71db69..c95e04e 100644
--- a/examples/activeqt/CMakeLists.txt
+++ b/examples/activeqt/CMakeLists.txt
@@ -1,17 +1,8 @@
-# Generated from activeqt.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
-add_subdirectory(comapp)
-add_subdirectory(hierarchy)
-add_subdirectory(menus)
-add_subdirectory(multiple)
-add_subdirectory(simple)
-add_subdirectory(wrapper)
-if(MINGW OR QT_BUILD_SHARED_LIBS)
- add_subdirectory(mediaplayer)
-endif()
-if(TARGET Qt6::OpenGLWidgets AND QT_FEATURE_opengl AND NOT QT_FEATURE_opengles2) # special case
- add_subdirectory(opengl)
-endif()
-if(TARGET Qt::QuickControls2)
- add_subdirectory(simpleqml)
+if(MSVC)
+ qt_internal_add_example(comapp)
+ qt_internal_add_example(simple)
+ qt_internal_add_example(wrapper)
endif()