summaryrefslogtreecommitdiffstats
path: root/examples/activeqt/comapp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/activeqt/comapp/CMakeLists.txt')
-rw-r--r--examples/activeqt/comapp/CMakeLists.txt14
1 files changed, 3 insertions, 11 deletions
diff --git a/examples/activeqt/comapp/CMakeLists.txt b/examples/activeqt/comapp/CMakeLists.txt
index f27518c..87f180d 100644
--- a/examples/activeqt/comapp/CMakeLists.txt
+++ b/examples/activeqt/comapp/CMakeLists.txt
@@ -15,20 +15,12 @@ endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/activeqt/comapp")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS AxServer)
-find_package(Qt6 COMPONENTS Widgets)
-
-qt_add_executable(comapp
+find_package(Qt6 COMPONENTS Core Gui AxServer Widgets)
+qt6_add_axserver_executable(comapp
main.cpp
-)
-set_target_properties(comapp PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
+ comapp.rc
)
target_link_libraries(comapp PUBLIC
- Qt::AxServer
Qt::Core
Qt::Gui
Qt::Widgets