summaryrefslogtreecommitdiffstats
path: root/examples/activeqt/menus/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/activeqt/menus/CMakeLists.txt')
-rw-r--r--examples/activeqt/menus/CMakeLists.txt38
1 files changed, 0 insertions, 38 deletions
diff --git a/examples/activeqt/menus/CMakeLists.txt b/examples/activeqt/menus/CMakeLists.txt
deleted file mode 100644
index 1bf6a6b..0000000
--- a/examples/activeqt/menus/CMakeLists.txt
+++ /dev/null
@@ -1,38 +0,0 @@
-# Generated from menus.pro.
-
-cmake_minimum_required(VERSION 3.14)
-project(menusax LANGUAGES CXX)
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/activeqt/menus")
-
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets)
-find_package(Qt6 COMPONENTS AxServer)
-
-add_qt_gui_executable(menusax
- main.cpp
- menus.cpp menus.h
-)
-target_link_libraries(menusax PUBLIC
- Qt::AxServer
- Qt::Core
- Qt::Gui
- Qt::Widgets
-)
-
-install(TARGETS menusax
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)