summaryrefslogtreecommitdiffstats
path: root/examples/activeqt/opengl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/activeqt/opengl/CMakeLists.txt')
-rw-r--r--examples/activeqt/opengl/CMakeLists.txt43
1 files changed, 0 insertions, 43 deletions
diff --git a/examples/activeqt/opengl/CMakeLists.txt b/examples/activeqt/opengl/CMakeLists.txt
deleted file mode 100644
index 5c08b0c..0000000
--- a/examples/activeqt/opengl/CMakeLists.txt
+++ /dev/null
@@ -1,43 +0,0 @@
-# Generated from opengl.pro.
-
-cmake_minimum_required(VERSION 3.14)
-project(openglax LANGUAGES CXX)
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/activeqt/opengl")
-
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets)
-find_package(Qt6 COMPONENTS AxServer)
-find_package(Qt6 COMPONENTS OpenGL)
-find_package(Qt6 COMPONENTS OpenGLWidgets)
-
-add_qt_gui_executable(openglax
- glbox.cpp glbox.h
- globjwin.cpp globjwin.h
- main.cpp
-)
-target_link_libraries(openglax PUBLIC
- Qt::AxServer
- Qt::Core
- Qt::Gui
- Qt::OpenGL
- Qt::OpenGLWidgets
- Qt::Widgets
-)
-
-install(TARGETS openglax
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)